summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/unpaper/unpaper-9999.ebuild')
-rw-r--r--app-text/unpaper/unpaper-9999.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-text/unpaper/unpaper-9999.ebuild b/app-text/unpaper/unpaper-9999.ebuild
index cb59b6c27de1..a26b83763386 100644
--- a/app-text/unpaper/unpaper-9999.ebuild
+++ b/app-text/unpaper/unpaper-9999.ebuild
@@ -1,14 +1,16 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
+inherit meson
if [[ ${PV} == *9999 ]]; then
EGIT_REPO_URI="https://github.com/Flameeyes/unpaper.git"
- inherit git-r3 autotools
+ inherit git-r3
else
SRC_URI="https://www.flameeyes.eu/files/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~arm64 ~x86"
fi
DESCRIPTION="Post-processor for scanned and photocopied book pages"
@@ -17,18 +19,13 @@ HOMEPAGE="https://www.flameeyes.eu/projects/unpaper"
LICENSE="GPL-2"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=media-video/ffmpeg-2:0=[encode]"
-DEPEND="dev-libs/libxslt
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/docbook-xsl-ns-stylesheets
- virtual/pkgconfig
- ${RDEPEND}"
-
-# gcc can generate slightly different code that leads to slightly different
-# images. Wait until we get a better testsuite.
-RESTRICT="test"
-
-src_prepare() {
- default
- [[ ${PV} == *9999 ]] && eautoreconf
-}
+ dev-libs/libxslt
+ dev-python/sphinx
+ test? ( dev-python/pytest )
+"