summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/wscr/wscr-1.2-r1.ebuild')
-rw-r--r--app-text/wscr/wscr-1.2-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-text/wscr/wscr-1.2-r1.ebuild b/app-text/wscr/wscr-1.2-r1.ebuild
new file mode 100644
index 000000000000..8ba24062d0df
--- /dev/null
+++ b/app-text/wscr/wscr-1.2-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A Lightweight and Fast Anagram Solver"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI="http://dev.gentoo.org/~jer/${P}.tar.gz"
+LICENSE="public-domain"
+SLOT="0"
+
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE=""
+RDEPEND="sys-apps/miscfiles"
+
+src_prepare() {
+ sed -i 's#"/usr/dict/words";#"/usr/share/dict/words";#' wscr.h || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin wscr
+ doman wscr.6
+ dodoc README
+}