summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapers/xapers-0.9.0.ebuild')
-rw-r--r--app-text/xapers/xapers-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/xapers/xapers-0.9.0.ebuild b/app-text/xapers/xapers-0.9.0.ebuild
new file mode 100644
index 000000000000..f2d6b0f70140
--- /dev/null
+++ b/app-text/xapers/xapers-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2016-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Personal document indexing system"
+HOMEPAGE="https://finestructure.net/xapers/ https://gitlab.com/jrollins/xapers/"
+SRC_URI="https://gitlab.com/jrollins/${PN}/-/archive/${PV}/${P}.tar.gz"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="app-text/poppler[utils]
+ dev-libs/xapian-bindings[python,${PYTHON_USEDEP}]
+ dev-python/pybtex[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ x11-misc/xclip
+ x11-misc/xdg-utils"
+
+BDEPEND="test? ( ${RDEPEND} )"
+
+python_test() {
+ cd test || die
+ ./all || die
+}