summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xapian-omega/xapian-omega-1.4.22.ebuild')
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.22.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-text/xapian-omega/xapian-omega-1.4.22.ebuild b/app-text/xapian-omega/xapian-omega-1.4.22.ebuild
new file mode 100644
index 000000000000..3dbebdbb01ed
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+HOMEPAGE="https://xapian.org/"
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libpcre2:=
+ ~dev-libs/xapian-${PV}:0/30
+ sys-apps/file
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega || die
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}