summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xiphos/files')
-rw-r--r--app-text/xiphos/files/xiphos-4.2.1-appdata_metainfo.patch11
-rw-r--r--app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch10
-rw-r--r--app-text/xiphos/files/xiphos-4.2.1-webkit41.patch20
3 files changed, 41 insertions, 0 deletions
diff --git a/app-text/xiphos/files/xiphos-4.2.1-appdata_metainfo.patch b/app-text/xiphos/files/xiphos-4.2.1-appdata_metainfo.patch
new file mode 100644
index 000000000000..fddfd2eca957
--- /dev/null
+++ b/app-text/xiphos/files/xiphos-4.2.1-appdata_metainfo.patch
@@ -0,0 +1,11 @@
+--- a/desktop/CMakeLists.txt
++++ b/desktop/CMakeLists.txt
+@@ -96,7 +96,7 @@
+ )
+ # install file
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${PROJECT_NAME}.appdata.xml
+- DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/appdata
++ DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/metainfo
+ COMPONENT data
+ )
+
diff --git a/app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch b/app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch
new file mode 100644
index 000000000000..10bca560fb03
--- /dev/null
+++ b/app-text/xiphos/files/xiphos-4.2.1-glib_version_min_required.patch
@@ -0,0 +1,10 @@
+--- a/cmake/config.h.cmake.in
++++ b/cmake/config.h.cmake.in
+@@ -63,5 +63,7 @@
+ // strcasestr
+ #cmakedefine HAVE_STRCASESTR 1
+
++// glib-2.68.0+ compatibility
++#define GLIB_VERSION_MIN_REQUIRED (GLIB_VERSION_2_26)
+
+ #endif
diff --git a/app-text/xiphos/files/xiphos-4.2.1-webkit41.patch b/app-text/xiphos/files/xiphos-4.2.1-webkit41.patch
new file mode 100644
index 000000000000..8de40e28c64e
--- /dev/null
+++ b/app-text/xiphos/files/xiphos-4.2.1-webkit41.patch
@@ -0,0 +1,20 @@
+--- a/cmake/XiphosDependencies.cmake
++++ b/cmake/XiphosDependencies.cmake
+@@ -84,7 +84,7 @@
+ "gdk-pixbuf-2.0"
+ "gio-2.0"
+ "gobject-2.0"
+- "libsoup-2.4"
++ "libsoup-3.0"
+ "pango"
+ "minizip"
+ "zlib"
+@@ -144,7 +144,7 @@
+ # Gtk+-3.0 + Webkit2 + GtkHtml-editor
+ pkg_check_modules(Gtk REQUIRED IMPORTED_TARGET
+ "gtk+-3.0"
+- "webkit2gtk-4.0"
++ "webkit2gtk-4.1"
+ )
+ endif()
+ endif (GTK2)