summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xmldiff/xmldiff-2.6.3.ebuild')
-rw-r--r--app-text/xmldiff/xmldiff-2.6.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-text/xmldiff/xmldiff-2.6.3.ebuild b/app-text/xmldiff/xmldiff-2.6.3.ebuild
new file mode 100644
index 000000000000..9814f09052d0
--- /dev/null
+++ b/app-text/xmldiff/xmldiff-2.6.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A tool that figures out the differences between two similar XML files"
+HOMEPAGE="
+ https://github.com/Shoobx/xmldiff
+ https://pypi.org/project/xmldiff/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~ia64 ppc sparc x86 ~x86-linux"
+
+RDEPEND="
+ >=dev-python/lxml-3.1.0[${PYTHON_USEDEP}]
+"
+
+DOCS=( CHANGES.rst README.rst )
+
+distutils_enable_tests unittest