summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xmltoman/xmltoman-0.6.ebuild')
-rw-r--r--app-text/xmltoman/xmltoman-0.6.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-text/xmltoman/xmltoman-0.6.ebuild b/app-text/xmltoman/xmltoman-0.6.ebuild
new file mode 100644
index 000000000000..2ae15fdeec2d
--- /dev/null
+++ b/app-text/xmltoman/xmltoman-0.6.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Simple scripts for converting xml to groff or html"
+HOMEPAGE="https://sourceforge.net/projects/xmltoman/"
+SRC_URI="https://github.com/atsb/xmltoman/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/XML-Parser
+"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-generate-man-pages.patch
+)
+
+src_install() {
+ # 'make install' requires GNU install, upstream is dead and carrying
+ # a patch is more space than redoing it here
+ dobin xmltoman xmlmantohtml
+
+ insinto /usr/share/xmltoman
+ doins xmltoman.{css,dtd,xsl}
+
+ dodoc README
+ doman xmltoman.1 xmlmantohtml.1
+}