summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch')
-rw-r--r--app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch b/app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch
new file mode 100644
index 000000000000..c53b63588c43
--- /dev/null
+++ b/app-text/xournalpp/files/xournalpp-1.1.3-lua-5-4.patch
@@ -0,0 +1,14 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -148,9 +148,9 @@ if (ENABLE_CPPUNIT)
+ endif (ENABLE_CPPUNIT)
+
+ # Plugins / scripting
+-find_package (Lua 5.3 EXACT)
++find_package (Lua ${LUA_VERSION} EXACT)
+ if (NOT Lua_FOUND)
+- find_package (Lua 5.3) # Lua 5.4 is only supported with cmake >=3.18
++ find_package (Lua ${LUA_VERSION}) # Lua 5.4 is only supported with cmake >=3.18
+ endif()
+
+ if (Lua_FOUND)