summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/yelp-tools/yelp-tools-42.1.ebuild')
-rw-r--r--app-text/yelp-tools/yelp-tools-42.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-text/yelp-tools/yelp-tools-42.1.ebuild b/app-text/yelp-tools/yelp-tools-42.1.ebuild
new file mode 100644
index 000000000000..2f882d1a7ee2
--- /dev/null
+++ b/app-text/yelp-tools/yelp-tools-42.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+inherit gnome2 meson python-single-r1
+
+DESCRIPTION="Collection of tools for building and converting documentation"
+HOMEPAGE="https://wiki.gnome.org/Apps/Yelp/Tools"
+
+LICENSE="|| ( GPL-2+ freedist ) GPL-2+" # yelp.m4 is GPL2 || freely distributable
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep 'dev-python/lxml[${PYTHON_USEDEP}]')
+ >=dev-libs/libxml2-2.6.12
+ >=dev-libs/libxslt-1.1.8
+ dev-util/itstool
+ >=gnome-extra/yelp-xsl-3.38
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ meson_src_install
+ python_fix_shebang "${ED}"/usr/bin/yelp-{build,check,new}
+}