summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-cb/zathura-cb-9999.ebuild')
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index 5e59ea0d4e25..fa6f6f40d74b 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit meson
+inherit meson xdg
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
EGIT_BRANCH="develop"
else
- KEYWORDS="~amd64 ~arm ~x86"
- SRC_URI="https://pwmt.org/projects/zathura/plugins/download/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~riscv ~x86"
+ SRC_URI="https://pwmt.org/projects/zathura-cb/download/${P}.tar.xz"
fi
DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
@@ -20,11 +20,15 @@ HOMEPAGE="https://pwmt.org/projects/zathura-cb/"
LICENSE="ZLIB"
SLOT="0"
-DEPEND=">=app-text/zathura-0.3.9
+RDEPEND="app-arch/libarchive:=
+ >=app-text/zathura-0.3.9
dev-libs/girara
dev-libs/glib:2
- x11-libs/cairo"
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2[jpeg]
+ x11-libs/gtk+:3"
-RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
BDEPEND="virtual/pkgconfig"