summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-djvu/zathura-djvu-9999.ebuild')
-rw-r--r--app-text/zathura-djvu/zathura-djvu-9999.ebuild24
1 files changed, 11 insertions, 13 deletions
diff --git a/app-text/zathura-djvu/zathura-djvu-9999.ebuild b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
index 0cec0327dc88..810861d8da93 100644
--- a/app-text/zathura-djvu/zathura-djvu-9999.ebuild
+++ b/app-text/zathura-djvu/zathura-djvu-9999.ebuild
@@ -1,26 +1,24 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils toolchain-funcs
-[[ ${PV} == 9999* ]] && inherit git-2
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-djvu.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
DESCRIPTION="DjVu plug-in for zathura"
HOMEPAGE="http://pwmt.org/projects/zathura/"
-if ! [[ ${PV} == 9999* ]]; then
-SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
-fi
-EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
-EGIT_BRANCH="develop"
LICENSE="ZLIB"
SLOT="0"
-if ! [[ ${PV} == 9999* ]]; then
-KEYWORDS="~amd64 ~arm ~x86"
-else
-KEYWORDS=""
-fi
IUSE=""
RDEPEND=">=app-text/djvu-3.5.24-r1:=
@@ -30,7 +28,7 @@ RDEPEND=">=app-text/djvu-3.5.24-r1:=
DEPEND="${RDEPEND}
virtual/pkgconfig"
-pkg_setup() {
+src_configure() {
myzathuraconf=(
CC="$(tc-getCC)"
LD="$(tc-getLD)"