summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura-pdf-poppler/zathura-pdf-poppler-0.3.2.ebuild')
-rw-r--r--app-text/zathura-pdf-poppler/zathura-pdf-poppler-0.3.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-text/zathura-pdf-poppler/zathura-pdf-poppler-0.3.2.ebuild b/app-text/zathura-pdf-poppler/zathura-pdf-poppler-0.3.2.ebuild
new file mode 100644
index 000000000000..4c9b1c46bdfe
--- /dev/null
+++ b/app-text/zathura-pdf-poppler/zathura-pdf-poppler-0.3.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-pdf-poppler.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+ SRC_URI="https://github.com/pwmt/zathura-pdf-poppler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="PDF plug-in for zathura"
+HOMEPAGE="https://pwmt.org/projects/zathura-pdf-poppler"
+
+LICENSE="ZLIB"
+SLOT="0"
+
+DEPEND=">=app-text/poppler-21.12.0:=[cairo]
+ >=app-text/zathura-0.5.3:=
+ dev-libs/girara
+ dev-libs/glib:2"
+
+RDEPEND="${DEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}