summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/zathura/zathura-9999.ebuild')
-rw-r--r--app-text/zathura/zathura-9999.ebuild72
1 files changed, 42 insertions, 30 deletions
diff --git a/app-text/zathura/zathura-9999.ebuild b/app-text/zathura/zathura-9999.ebuild
index fcb0645c0898..3cf03fc8f6e7 100644
--- a/app-text/zathura/zathura-9999.ebuild
+++ b/app-text/zathura/zathura-9999.ebuild
@@ -1,48 +1,65 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit gnome2-utils meson virtualx xdg-utils
+inherit meson virtualx xdg
DESCRIPTION="A highly customizable and functional document viewer"
-HOMEPAGE="http://pwmt.org/projects/zathura/"
+HOMEPAGE="https://pwmt.org/projects/zathura/"
if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://git.pwmt.org/pwmt/${PN}.git"
EGIT_BRANCH="develop"
else
- SRC_URI="https://pwmt.org/projects/zathura/download/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="
+ https://github.com/pwmt/zathura/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://cdn.turret.cyou/e28b2f940d1a19a74ecbfd80ea4477c5ea9ac627/${P}-manpages.tar.xz
+ "
+ KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
fi
LICENSE="ZLIB"
-SLOT="0"
-IUSE="+magic seccomp sqlite synctex test"
+SLOT="0/5.6"
+IUSE="seccomp sqlite synctex test"
-RDEPEND=">=dev-libs/girara-0.3.1
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/girara-0.4.1
>=dev-libs/glib-2.50:2
- dev-python/sphinx
- >=sys-devel/gettext-0.19.8
+ dev-libs/json-glib
+ sys-apps/file
x11-libs/cairo
>=x11-libs/gtk+-3.22:3
- magic? ( sys-apps/file )
seccomp? ( sys-libs/libseccomp )
- sqlite? ( >=dev-db/sqlite-3.5.9:3 )
- synctex? ( app-text/texlive-core )"
-
-DEPEND="${RDEPEND}
- test? ( dev-libs/check )"
+ sqlite? ( >=dev-db/sqlite-3.6.23:3 )
+ synctex? ( app-text/texlive-core )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-libs/check
+ >=x11-libs/gtk+-3.22:3[X]
+ )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
-BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}/zathura-0.5.4-disable-seccomp-tests.patch"
+)
src_configure() {
local emesonargs=(
- -Denable-magic=$(usex magic true false)
- -Denable-seccomp=$(usex seccomp true false)
- -Denable-sqlite=$(usex sqlite true false)
- -Denable-synctex=$(usex synctex true false)
+ -Dconvert-icon=disabled
+ -Dmanpages=disabled
+ -Dseccomp=$(usex seccomp enabled disabled)
+ -Dsqlite=$(usex sqlite enabled disabled)
+ -Dsynctex=$(usex synctex enabled disabled)
)
meson_src_configure
}
@@ -51,12 +68,7 @@ src_test() {
virtx meson_src_test
}
-pkg_postinst() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
- xdg_desktop_database_update
+src_install() {
+ meson_src_install
+ [[ ${PV} != *9999 ]] && doman "${WORKDIR}"/man/zathura*
}