summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/fluxbox-syntax')
-rw-r--r--app-vim/fluxbox-syntax/Manifest1
-rw-r--r--app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild30
-rw-r--r--app-vim/fluxbox-syntax/metadata.xml5
3 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/fluxbox-syntax/Manifest b/app-vim/fluxbox-syntax/Manifest
new file mode 100644
index 000000000000..7a09cddd0caa
--- /dev/null
+++ b/app-vim/fluxbox-syntax/Manifest
@@ -0,0 +1 @@
+DIST fluxbox-syntax-1.5.tar.bz2 1376 SHA256 bd59dbbd4d3a9ccf426ecf1af6e470daf45f97832d901a5cde55a82dcdf8cfaf SHA512 0567af6fe0994ea228ac56c3a26485ba5cce7762e3d70d6dced978e56017f6769072c83ae68125de3e03190562a7a10102bef038c02ae148cf70cc0c5951b8df WHIRLPOOL 346e70a9bf402780e61f1b7c942db7e56cdec35209801954041591903df7dac3aee43419b9e89901385e70e22db9a013104c6046ac69bc1c69fdc32fee4a0740
diff --git a/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
new file mode 100644
index 000000000000..d9c7b698fb3d
--- /dev/null
+++ b/app-vim/fluxbox-syntax/fluxbox-syntax-1.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: fluxbox files syntax and indent"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=679"
+LICENSE="vim"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+RDEPEND="${RDEPEND} >=app-vim/genindent-1.0"
+
+VIM_PLUGIN_HELPTEXT=\
+"This plugin provides syntax highlighting and indent settings for fluxbox
+menus and similar files. Upstream don't provide us with an ftdetect file,
+but a simple one has been created for you by this ebuild. You can manually
+set the filetype using :set filetype=fluxbox if necessary."
+
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # no ftdetect file provided. lame...
+ mkdir ftdetect
+ echo "au BufNewFile,BufRead /*/*fluxbox/*menu set filetype=fluxbox" \
+ > ftdetect/fluxbox.vim
+}
diff --git a/app-vim/fluxbox-syntax/metadata.xml b/app-vim/fluxbox-syntax/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/fluxbox-syntax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>