summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/minibufexpl/minibufexpl-6.4.3.ebuild')
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.4.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-vim/minibufexpl/minibufexpl-6.4.3.ebuild b/app-vim/minibufexpl/minibufexpl-6.4.3.ebuild
new file mode 100644
index 000000000000..6b53d2fe1987
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.4.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit vim-plugin
+
+MY_PN="${PN}.vim"
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="https://github.com/fholgado/minibufexpl.vim"
+SRC_URI="https://github.com/fholgado/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="bufexplorer.vim"
+KEYWORDS="amd64 ~mips ppc x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir "${S}"/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/${PN}.vim \
+ > doc/${PN}.txt
+
+ # Discard unwanted files
+ rm .gitignore README project.html || die
+}