summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/slimv/slimv-0.9.12.ebuild')
-rw-r--r--app-vim/slimv/slimv-0.9.12.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/slimv/slimv-0.9.12.ebuild b/app-vim/slimv/slimv-0.9.12.ebuild
new file mode 100644
index 000000000000..0ffa4878879f
--- /dev/null
+++ b/app-vim/slimv/slimv-0.9.12.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin vcs-snapshot
+
+DESCRIPTION="vim plugin: aid Lisp development by providing a SLIME-like Lisp and Clojure REPL"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2531"
+SRC_URI="https://bitbucket.org/kovisoft/${PN}/get/${PV}.tar.bz2 -> ${P}.tar.bz2"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )
+ >=dev-lang/python-2.4
+ || (
+ dev-lisp/clisp
+ dev-lang/clojure
+ dev-lisp/abcl
+ dev-lisp/clozurecl
+ dev-lisp/ecls
+ dev-lisp/sbcl
+ )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ # remove emacs related files
+ rm -r slime swank-clojure || die
+}