summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/tcomment')
-rw-r--r--app-vim/tcomment/Manifest2
-rw-r--r--app-vim/tcomment/metadata.xml3
-rw-r--r--app-vim/tcomment/tcomment-3.08.1.ebuild28
-rw-r--r--app-vim/tcomment/tcomment-4.00.ebuild26
-rw-r--r--app-vim/tcomment/tcomment-9999.ebuild28
5 files changed, 29 insertions, 58 deletions
diff --git a/app-vim/tcomment/Manifest b/app-vim/tcomment/Manifest
index b3eba0f0b274..50b4dd8b93c4 100644
--- a/app-vim/tcomment/Manifest
+++ b/app-vim/tcomment/Manifest
@@ -1 +1 @@
-DIST tcomment-3.08.1.tar.gz 49918 BLAKE2B df63a01432101e018a39f7b54dec0b91b415263e2b6c0f3e63521e1abe2247a005a1fc900cd6d18cfd908f75ae4b5767a5f7dc21ae620985d3465676c456a389 SHA512 609d5eb1e7785fb1af829000ab27ab63ac2bb7550bcd0f91c7c35f0a8c4b879e5348745f57b11d1e24d37920056ca55da8863e15e40d6fe289617d5d898a4177
+DIST tcomment-4.00.tar.gz 58709 BLAKE2B 64285c64d65e7308e3cb34494f1b49584f54707ba9f4e86a40a72c1434670819c412b68e4a30f296ce531913b054d482f5743ee7e6fd81baa5c3ee1d46dc8d01 SHA512 b072ec4b136ef6ea14e91883a77b036a26b2e2c0f6cabdce70e4aea2cf37a2c4b7becc0770ddfc8b7260a52cda729a0e4b8ff4a067c81bcbbe0f0e896b9e66c4
diff --git a/app-vim/tcomment/metadata.xml b/app-vim/tcomment/metadata.xml
index 9e97359a2544..d62cd1f89679 100644
--- a/app-vim/tcomment/metadata.xml
+++ b/app-vim/tcomment/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>vim@gentoo.org</email>
@@ -8,4 +8,5 @@
<upstream>
<remote-id type="github">tomtom/tcomment_vim</remote-id>
</upstream>
+ <stabilize-allarches/>
</pkgmetadata>
diff --git a/app-vim/tcomment/tcomment-3.08.1.ebuild b/app-vim/tcomment/tcomment-3.08.1.ebuild
deleted file mode 100644
index 0e8c814890a6..000000000000
--- a/app-vim/tcomment/tcomment-3.08.1.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-MY_PN="tcomment_vim"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/tomtom/tcomment_vim.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="amd64 x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="vim plugin: an extensible and universal comment toggler"
-HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
-LICENSE="GPL-3"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-src_prepare() {
- default
- rm -r README LICENSE.TXT etc spec addon* || die
-}
diff --git a/app-vim/tcomment/tcomment-4.00.ebuild b/app-vim/tcomment/tcomment-4.00.ebuild
new file mode 100644
index 000000000000..583ddd7290c8
--- /dev/null
+++ b/app-vim/tcomment/tcomment-4.00.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+MY_PN="tcomment_vim"
+
+DESCRIPTION="vim plugin: an extensible and universal comment toggler"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173
+ https://github.com/tomtom/tcomment_vim"
+SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+LICENSE="GPL-3"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+DOCS=( CHANGES.TXT README )
+
+src_prepare() {
+ default
+ rm -r etc spec addon* || die
+}
diff --git a/app-vim/tcomment/tcomment-9999.ebuild b/app-vim/tcomment/tcomment-9999.ebuild
deleted file mode 100644
index 1ac364c516dd..000000000000
--- a/app-vim/tcomment/tcomment-9999.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit vim-plugin
-
-MY_PN="tcomment_vim"
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/tomtom/tcomment_vim.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/tomtom/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
-DESCRIPTION="vim plugin: an extensible and universal comment toggler"
-HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1173 https://github.com/tomtom/tcomment_vim"
-LICENSE="GPL-3"
-
-VIM_PLUGIN_HELPFILES="${PN}.txt"
-
-src_prepare() {
- default
- rm -r README LICENSE.TXT etc spec addon* || die
-}