summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimcommander')
-rw-r--r--app-vim/vimcommander/Manifest2
-rw-r--r--app-vim/vimcommander/metadata.xml5
-rw-r--r--app-vim/vimcommander/vimcommander-0.80.ebuild19
-rw-r--r--app-vim/vimcommander/vimcommander-0.81.ebuild13
4 files changed, 39 insertions, 0 deletions
diff --git a/app-vim/vimcommander/Manifest b/app-vim/vimcommander/Manifest
new file mode 100644
index 000000000000..c66076306798
--- /dev/null
+++ b/app-vim/vimcommander/Manifest
@@ -0,0 +1,2 @@
+DIST vimcommander-0.81.tar.bz2 8447 SHA256 0f2f2f4c0d9f8d9207dff30c961a7f2a179fb01e6136c97e662b082889415ef2 SHA512 903c97cd56d24f9c568b863c52f69878bc3aab7f8728de38697437bf0c0697b585b1d5ac5d824d472518dabf0f2367dff24b1881742b7d28c0f5452d74c37fab WHIRLPOOL cc24b8b80b2bc750f9c22010a443d0c8ae04a2477ee34b446fd14e4be271536f6691a6b0b52757e90bfae88405141deb67619951aed672fb5ac3355ead32f875
+DIST vimcommander-80.tar.bz2 8238 SHA256 e0349b15d785875ac50790a31147b098c5cced343f02a78165168e4a739bce28 SHA512 0c64c005c48bf1169d23a49b474e617bba0e1968349b22639065d4d2bbe2f70f291279c03322452201f9481bcdf4f63d3ec5cb4feaafcf37b6c6364949644647 WHIRLPOOL 0a0092db44346d346b258b3820c406a5e6d54246f0bcd38b64f1e42a18900194e87f8f5bc0514934b9109acac93de90e708edf9634a20b64510057bb3976466d
diff --git a/app-vim/vimcommander/metadata.xml b/app-vim/vimcommander/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/vimcommander/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/vimcommander/vimcommander-0.80.ebuild b/app-vim/vimcommander/vimcommander-0.80.ebuild
new file mode 100644
index 000000000000..3fb0c4498800
--- /dev/null
+++ b/app-vim/vimcommander/vimcommander-0.80.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit vim-plugin
+
+MY_PV=${PV/0./}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="vim plugin: Total Commander style file explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=808"
+SRC_URI="mirror://gentoo/${MY_P}.tar.bz2"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="vimcommander"
+
+S=${WORKDIR}/${MY_P}
diff --git a/app-vim/vimcommander/vimcommander-0.81.ebuild b/app-vim/vimcommander/vimcommander-0.81.ebuild
new file mode 100644
index 000000000000..b7b9bc7bab26
--- /dev/null
+++ b/app-vim/vimcommander/vimcommander-0.81.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Total Commander style file explorer"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=808"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"