summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild')
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild31
1 files changed, 3 insertions, 28 deletions
diff --git a/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild b/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
index d7c15479021b..36ebfb95a0a7 100644
--- a/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
+++ b/app-vim/vimoutliner/vimoutliner-0.3.6-r1.ebuild
@@ -1,31 +1,19 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-
-inherit vim-plugin python-single-r1
+inherit vim-plugin
DESCRIPTION="vim plugin: easy and fast outlining"
HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.zip -> ${P}.zip"
LICENSE="GPL-2"
-KEYWORDS="~amd64 ~x86"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+KEYWORDS="alpha amd64 ia64 ~mips ppc sparc x86"
VIM_PLUGIN_HELPFILES="vimoutliner"
VIM_PLUGIN_MESSAGES="filetype"
-PATCHES=( "${FILESDIR}/${P}-fix-shebangs.patch" )
-
-RDEPEND="dev-python/autopep8"
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
src_prepare() {
default
sed -i -e '/^if exists/,/endif/d' ftdetect/vo_base.vim || die
@@ -33,16 +21,3 @@ src_prepare() {
rm -v install.sh || die
find "${S}" -type f -exec chmod a+r {} \; || die
}
-
-src_compile() {
- local pyscript _pyscript
- for pyscript in $(find "${S}" -type f -name \*.py); do
- _pyscript=$(basename "${pyscript}")
- einfo "Processing ${_pyscript}"
- sed -i -e 's#[ \t]*$##g;' "${pyscript}" || die
- 2to3 --no-diffs -w -n "${pyscript}" 2> /dev/null || die
- autopep8 -i "${pyscript}" || die
- python_fix_shebang -q "${pyscript}" || die
- eend $?
- done
-}