summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/vimtex/vimtex-20180324.ebuild')
-rw-r--r--app-vim/vimtex/vimtex-20180324.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-vim/vimtex/vimtex-20180324.ebuild b/app-vim/vimtex/vimtex-20180324.ebuild
new file mode 100644
index 000000000000..d4031034c014
--- /dev/null
+++ b/app-vim/vimtex/vimtex-20180324.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/lervag/vimtex.git"
+ inherit git-r3
+else
+ inherit vcs-snapshot
+ COMMIT_HASH="17d809706edcb277f1ee7fa5e33aff3619926fe4"
+ SRC_URI="https://github.com/lervag/vimtex/archive/${COMMIT_HASH}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: a modern vim plugin for editing LaTeX files"
+HOMEPAGE="https://github.com/lervag/vimtex"
+LICENSE="MIT"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+RDEPEND="
+ !app-vim/vim-latex
+ !app-vim/automatictexplugin
+ virtual/latex-base
+ dev-tex/latexmk
+"
+
+src_prepare() {
+ default
+
+ # remove unwanted files
+ rm -r *.md media test || die
+}