summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim/voom')
-rw-r--r--app-vim/voom/Manifest4
-rw-r--r--app-vim/voom/metadata.xml5
-rw-r--r--app-vim/voom/voom-4.6.ebuild17
-rw-r--r--app-vim/voom/voom-4.7.ebuild20
-rw-r--r--app-vim/voom/voom-5.0.ebuild16
-rw-r--r--app-vim/voom/voom-5.1.ebuild16
6 files changed, 78 insertions, 0 deletions
diff --git a/app-vim/voom/Manifest b/app-vim/voom/Manifest
new file mode 100644
index 000000000000..ccd3c53d9d71
--- /dev/null
+++ b/app-vim/voom/Manifest
@@ -0,0 +1,4 @@
+DIST voom-4.6.tar.bz2 108007 SHA256 c81b6c1f425ea49aea342a949c8fb45ee659f8f301913f7097b4afe9ce6cf543 SHA512 a29cf58f22edf0e6b1f381f703fea443fd4719262ae507a871f70b7a2aad9c4771642d7024c61fb809876e6c9779d901308cfa63e229c99801127a74883fcbba WHIRLPOOL d68b4efcefa194f12642f702acd659c0f6d212a18369492603e19ffe6a421310523bbce843e54553f96039b2ac1b750cc52836b83548f0973266eb416f36f3f1
+DIST voom-4.7.tar.bz2 109314 SHA256 744b2ea7f6ccdfcd10ad1815e0d233d65e3905e6bfdb91e041270555307b160e SHA512 83b600baa28c2af11028646c34e09fb28f35a7746c9c681e9dd789f3f8f0c37fe4bcf57e34abcf5c462703cbc4d44244345f298d66109bcd3d8364a313eb20b5 WHIRLPOOL 480e56b8dbd9192669de58ade5e4dab8012745c946d68ab89b65d0163415d57568f134970b2ffe1b43297747264b85dfdf48dcfe58f364398249972bbba113e2
+DIST voom-5.0.tar.bz2 99786 SHA256 9ee8d015ad2fab4ef975b6ac3c5785bb6a72d70e57db7a44d6f0ed537aee06e0 SHA512 9447fc65832aa0b7bd423a91d2f80979f44f9576af3a4eedb7bb7f6e3d6dc2732b6e18f57557099976630f3f8938134e0898393787768375d0edfab704590384 WHIRLPOOL 2ef7dd3e29d96217c4b4f38ed290cfec4feb1ce5d2694fdc8ce1f52159400afd12bc45a52bfbacc22449f05e2eaab939acecc2d3a94d8541c05b16d79fea0622
+DIST voom-5.1.tar.bz2 102211 SHA256 2af7f5589606ecb214671fc817aacf599f3bb39e38e295ff76891839b161e931 SHA512 3798c6d5079ebdf4f447f62613340e46a6b593e0a97226b0aecc90889c6cd2f6f2ce36eb88395a12a0e27ff3803c7693f1c56443928914bfea134d8a75df8c91 WHIRLPOOL 4c96caedc4413487c6fd213c62315334c9e8bc2707455413f0c39d297576d076bddc6a5cf99a99ecd40c55b453f370e8f021402c5139607cf55f79a7f3e153da
diff --git a/app-vim/voom/metadata.xml b/app-vim/voom/metadata.xml
new file mode 100644
index 000000000000..5fcb67350f69
--- /dev/null
+++ b/app-vim/voom/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>vim</herd>
+</pkgmetadata>
diff --git a/app-vim/voom/voom-4.6.ebuild b/app-vim/voom/voom-4.6.ebuild
new file mode 100644
index 000000000000..4f4b88f672ce
--- /dev/null
+++ b/app-vim/voom/voom-4.6.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="http://vim-voom.github.com/ http://www.vim.org/scripts/script.php?script_id=2657"
+LICENSE="WTFPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"
diff --git a/app-vim/voom/voom-4.7.ebuild b/app-vim/voom/voom-4.7.ebuild
new file mode 100644
index 000000000000..77964f679362
--- /dev/null
+++ b/app-vim/voom/voom-4.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="http://vim-voom.github.com/ http://www.vim.org/scripts/script.php?script_id=2657"
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"
+
+src_prepare() {
+ rm -r voom_extras || die
+}
diff --git a/app-vim/voom/voom-5.0.ebuild b/app-vim/voom/voom-5.0.ebuild
new file mode 100644
index 000000000000..ed55552e9989
--- /dev/null
+++ b/app-vim/voom/voom-5.0.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="http://vim-voom.github.com/ http://www.vim.org/scripts/script.php?script_id=2657"
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"
diff --git a/app-vim/voom/voom-5.1.ebuild b/app-vim/voom/voom-5.1.ebuild
new file mode 100644
index 000000000000..6a81da922764
--- /dev/null
+++ b/app-vim/voom/voom-5.1.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: emulates a two-pane text outliner"
+HOMEPAGE="http://vim-voom.github.com/ http://www.vim.org/scripts/script.php?script_id=2657"
+LICENSE="CC0-1.0"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"