summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/vimoutliner/Manifest1
-rw-r--r--app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-vim/vimoutliner/Manifest b/app-vim/vimoutliner/Manifest
index 84b8891b7dd8..e8ded346ceef 100644
--- a/app-vim/vimoutliner/Manifest
+++ b/app-vim/vimoutliner/Manifest
@@ -1 +1,2 @@
DIST vimoutliner-0.3.6.zip 249053 BLAKE2B 329fbf73423291598a104881299200153c6d98cf75f3884c690879dc3460c4190c09eefec55415589f16a426ee76911a8ee7761a158d76b9e84360f5fadb83eb SHA512 20d348ff1b1b9572956fdc56b75e742b25b7deac2637fa6972a1e451edc1f679d8255847a291b84c80866a9ad8a37421524b8eb33565a1bb32ff2b75d0b68dde
+DIST vimoutliner-0.4.0_p20180301.tar.gz 367361 BLAKE2B a97df5c154e6ed9b3209bd90bd57b4166877f02b9513351fda0e841de84334a1e592e1ed56b46cc59bc6bb64f3c763cdca81df3f8696f3c348a8ef4744124c02 SHA512 f9f369e7e7f09dac04b58a27a86dc2121b3aacd0002537db348517e779fd1b7c9e88ae905b4b42aace10f79cb8f91acada1ad58e26f2257e46d1af98347eab62
diff --git a/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild
new file mode 100644
index 000000000000..693542279762
--- /dev/null
+++ b/app-vim/vimoutliner/vimoutliner-0.4.0_p20180301.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin vcs-snapshot
+
+# Commit Date: 1 Mar 2018
+COMMIT="4f12628247940d98eedd594961695dc504261058"
+
+DESCRIPTION="Vim plugin for easy and fast outlining"
+HOMEPAGE="https://github.com/vimoutliner/vimoutliner"
+SRC_URI="https://github.com/vimoutliner/vimoutliner/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+VIM_PLUGIN_HELPFILES="vimoutliner"
+VIM_PLUGIN_MESSAGES="filetype"
+
+RDEPEND="dev-python/autopep8"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+
+ sed -i -e '1s:^:#!/usr/bin/python\n:' vimoutliner/scripts/otl2latex/otl2latex.py
+ find "${S}" -type f -exec chmod a+r {} \; || die
+}
+
+src_compile() {
+ local pyscript _pyscript
+ for pyscript in $(find "${S}" -type f -name \*.py); do
+ _pyscript=$(basename "${pyscript}")
+ [ ${_pyscript} == "otl.py" ] && continue
+ python_fix_shebang -q "${pyscript}"
+ done
+}