summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/aixlog/aixlog-9999.ebuild')
-rw-r--r--dev-cpp/aixlog/aixlog-9999.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-cpp/aixlog/aixlog-9999.ebuild b/dev-cpp/aixlog/aixlog-9999.ebuild
index 1246304bfa01..b1164d6bbd11 100644
--- a/dev-cpp/aixlog/aixlog-9999.ebuild
+++ b/dev-cpp/aixlog/aixlog-9999.ebuild
@@ -1,21 +1,20 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit cmake
DESCRIPTION="Header-only C++ logging library"
HOMEPAGE="https://github.com/badaix/aixlog"
if [[ ${PV} == *9999 ]] ; then
- inherit cmake-utils git-r3
+ inherit git-r3
EGIT_REPO_URI="https://github.com/badaix/aixlog.git"
EGIT_BRANCH="develop"
else
- inherit cmake-utils
-
- SRC_URI="https://github.com/badaix/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
+ SRC_URI="https://github.com/badaix/aixlog/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -25,5 +24,5 @@ SLOT="0"
src_configure() {
local mycmakeargs=( -DBUILD_EXAMPLE=OFF )
- cmake-utils_src_configure
+ cmake_src_configure
}