summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/catch/catch-1.9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-1.9999.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-cpp/catch/catch-1.9999.ebuild b/dev-cpp/catch/catch-1.9999.ebuild
index f8b78e009959..479fa612486c 100644
--- a/dev-cpp/catch/catch-1.9999.ebuild
+++ b/dev-cpp/catch/catch-1.9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit cmake-utils
+inherit cmake
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -12,7 +12,7 @@ if [[ ${PV} == *9999 ]]; then
else
MY_P=${PN^}-${PV}
SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ KEYWORDS="~amd64 ~ppc64 ~x86"
S="${WORKDIR}/${PN^}2-${PV}"
fi
@@ -25,16 +25,14 @@ SLOT="1"
IUSE="test"
RESTRICT="!test? ( test )"
-RDEPEND="!<dev-cpp/catch-1.12.2:0"
-
src_configure() {
local mycmakeargs=(
-DNO_SELFTEST=$(usex !test)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodoc -r docs/.
}