summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/catch/catch-9999.ebuild')
-rw-r--r--dev-cpp/catch/catch-9999.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
index 5318b054d396..1b1704c908ca 100644
--- a/dev-cpp/catch/catch-9999.ebuild
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-utils python-any-r1
+inherit cmake python-any-r1
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -13,9 +13,9 @@ if [[ ${PV} == *9999 ]]; then
else
MY_P=${PN^}2-${PV}
SRC_URI="https://github.com/catchorg/Catch2/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
- S=${WORKDIR}/${MY_P}
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
DESCRIPTION="Modern C++ header-only framework for unit-tests"
@@ -34,11 +34,13 @@ pkg_setup() {
src_configure() {
local mycmakeargs=(
+ -DCATCH_DEVELOPMENT_BUILD=ON
-DCATCH_ENABLE_WERROR=OFF
- -DBUILD_TESTING=$(usex test)
+ -DCATCH_BUILD_TESTING=$(usex test)
+ )
+ use test && mycmakeargs+=(
+ -DPYTHON_EXECUTABLE="${PYTHON}"
)
- use test &&
- mycmakeargs+=(-DPYTHON_EXECUTABLE="${PYTHON}")
- cmake-utils_src_configure
+ cmake_src_configure
}