summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/cctz/cctz-2.4.ebuild')
-rw-r--r--dev-cpp/cctz/cctz-2.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-cpp/cctz/cctz-2.4.ebuild b/dev-cpp/cctz/cctz-2.4.ebuild
new file mode 100644
index 000000000000..18994d1290b8
--- /dev/null
+++ b/dev-cpp/cctz/cctz-2.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ library for dealing with time zones and time conversion"
+HOMEPAGE="https://github.com/google/cctz"
+SRC_URI="https://github.com/google/cctz/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ test? (
+ dev-cpp/gtest
+ )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ -DBUILD_BENCHMARK=OFF
+ )
+ cmake_src_configure
+}