summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/Manifest2
-rw-r--r--dev-cpp/ctemplate/ctemplate-2.4.ebuild (renamed from dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild)15
-rw-r--r--dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch29
-rw-r--r--dev-cpp/ctemplate/metadata.xml2
4 files changed, 9 insertions, 39 deletions
diff --git a/dev-cpp/ctemplate/Manifest b/dev-cpp/ctemplate/Manifest
index 74737dea1ace..2f6b74dd23a9 100644
--- a/dev-cpp/ctemplate/Manifest
+++ b/dev-cpp/ctemplate/Manifest
@@ -1 +1 @@
-DIST ctemplate-2.3.tar.bz2 564389 BLAKE2B e0c95ac534eb0b7fdff3e87e08f3b1b8aa735bec8eef05bebcf87a51375cbc93e768a18ba005248edda023869b21679dbadaf3d6462e71666fa5d85b96172851 SHA512 546645389a8bfed59686b62b43cb7d53714ac98e1b75311c217bb0f3b6201d5d486766b1ce7e35bf15032372e45c36b27008f54085bd0c9ef0dd0b7e04b8e3f5
+DIST ctemplate-2.4.tar.gz 391923 BLAKE2B 96b585ed6ca323fc461857e1f2f381e0ca5c229d8c6039c24efcf34fb9ddf45cc36bef141af337e591e1cdd95ca510ea5ba1e539554322c578c25187b1906195 SHA512 4955489e7327bce18802d50fd9dfc8ac12af685e556d1c9d0eb2b7a2f4a9b6086e30be8388d694ec8912623738973d0c76e9ca97196c63c139ee5b468d4858b7
diff --git a/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
index a578d0f6a249..b1a2a9d2775c 100644
--- a/dev-cpp/ctemplate/ctemplate-2.3-r1.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-2.4.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{9..11} )
inherit autotools elisp-common python-any-r1
DESCRIPTION="A simple but powerful template language for C++"
HOMEPAGE="https://github.com/olafvdspek/ctemplate"
-SRC_URI="https://dev.gentoo.org/~pinkbyte/distfiles/${P}.tar.bz2"
+SRC_URI="https://github.com/OlafvdSpek/ctemplate/archive/${P}.tar.gz"
+S="${WORKDIR}/ctemplate-${P}"
LICENSE="BSD"
SLOT="0"
@@ -18,7 +19,7 @@ IUSE="doc emacs vim-syntax static-libs test"
DEPEND="test? ( ${PYTHON_DEPS} )"
RDEPEND="
- emacs? ( virtual/emacs )
+ emacs? ( >=app-editors/emacs-23.1:* )
vim-syntax? ( >=app-editors/vim-core-7 )"
SITEFILE="70ctemplate-gentoo.el"
@@ -26,8 +27,6 @@ SITEFILE="70ctemplate-gentoo.el"
# Some tests are broken in 2.3
RESTRICT="test"
-PATCHES=( "${FILESDIR}"/${PN}-2.3-fix-build-system.patch )
-
src_prepare() {
default
eautoreconf
@@ -48,7 +47,7 @@ src_compile() {
src_install() {
default
if ! use doc; then
- rm -r "${ED%/}"/usr/share/doc/${PF}/html || die
+ rm -r "${ED}"/usr/share/doc/${PF}/html || die
fi
if use vim-syntax; then
diff --git a/dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch b/dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch
deleted file mode 100644
index 4178f5ed3655..000000000000
--- a/dev-cpp/ctemplate/files/ctemplate-2.3-fix-build-system.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-* Do not override $(docdir) as userflag in the GNU conventions
-* Only build tests programs when running 'make check'
-
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -54,12 +54,11 @@
- src/ctemplate/per_expand_data.h.in \
- src/ctemplate/str_ref.h.in
-
--docdir = $(prefix)/share/doc/$(PACKAGE)-$(VERSION)
- ## This is for HTML and other documentation you want to install.
- ## Add your documentation files (in doc/) in addition to these
- ## top-level boilerplate files. Also add a TODO file if you have one.
--dist_doc_DATA = AUTHORS COPYING ChangeLog INSTALL NEWS README README_windows.txt \
-- doc/designstyle.css doc/index.html \
-+dist_doc_DATA = AUTHORS ChangeLog NEWS README README_windows.txt
-+dist_html_DATA = doc/designstyle.css doc/index.html \
- doc/howto.html doc/guide.html doc/reference.html \
- doc/tips.html doc/example.html doc/auto_escape.html \
- doc/xss_resources.html
-@@ -452,7 +451,7 @@
-
- ## This should always include $(TESTS), but may also include other
- ## binaries that you compile but don't want automatically installed.
--noinst_PROGRAMS = $(TESTS)
-+check_PROGRAMS = $(TESTS)
-
- rpm: dist-gzip packages/rpm.sh packages/rpm/rpm.spec
- @cd packages && ./rpm.sh ${PACKAGE} ${VERSION}
diff --git a/dev-cpp/ctemplate/metadata.xml b/dev-cpp/ctemplate/metadata.xml
index 2e7a1bb6b274..a65815958ecd 100644
--- a/dev-cpp/ctemplate/metadata.xml
+++ b/dev-cpp/ctemplate/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<!-- maintainer-needed -->
<upstream>