summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/curlpp/curlpp-0.8.1.ebuild')
-rw-r--r--dev-cpp/curlpp/curlpp-0.8.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-cpp/curlpp/curlpp-0.8.1.ebuild b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
new file mode 100644
index 000000000000..92293f3924f5
--- /dev/null
+++ b/dev-cpp/curlpp/curlpp-0.8.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="C++ wrapper for libcURL"
+HOMEPAGE="https://www.curlpp.org/"
+SRC_URI="https://github.com/jpbarrette/curlpp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND="net-misc/curl"
+DEPEND="${RDEPEND}"
+
+DOCS=( Readme.md doc/AUTHORS doc/TODO )
+
+PATCHES=( "${FILESDIR}"/${P}-fix-pkgconfig.patch )
+
+src_install() {
+ use doc && DOCS+=( doc/guide.pdf )
+
+ cmake_src_install
+
+ rm "${ED}"/usr/$(get_libdir)/libcurlpp.a || die
+
+ if use examples ; then
+ dodoc -r examples/
+ fi
+}