summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/edencommon')
-rw-r--r--dev-cpp/edencommon/Manifest1
-rw-r--r--dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild41
-rw-r--r--dev-cpp/edencommon/metadata.xml11
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-cpp/edencommon/Manifest b/dev-cpp/edencommon/Manifest
new file mode 100644
index 000000000000..8dad4592cb9c
--- /dev/null
+++ b/dev-cpp/edencommon/Manifest
@@ -0,0 +1 @@
+DIST edencommon-2023.06.19.00.gh.tar.gz 146697 BLAKE2B 8b2419671c50eea43aa4b8d5d85eee75ed24ff9745a71c2d11b1994605552ffc288b55520639585631aed0e2528482a01daa9b47ef676fed7c14b4c7d75d018f SHA512 47b37a6acf93a6c6f2903f3113021aa1d54230cf3e31a8071aa7f276601a8eae56bd95767ec23c3027695367261d4db1483b637513c72ce220778f1f1a4c42ce
diff --git a/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild b/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild
new file mode 100644
index 000000000000..1296800f7058
--- /dev/null
+++ b/dev-cpp/edencommon/edencommon-2023.06.19.00.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# These must be bumped together:
+# dev-cpp/edencommon
+# dev-cpp/folly
+# dev-util/watchman
+
+inherit cmake
+
+DESCRIPTION="Shared library for Watchman and Eden projects"
+HOMEPAGE="https://github.com/facebookexperimental/edencommon"
+SRC_URI="https://github.com/facebookexperimental/edencommon/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64"
+IUSE="llvm-libunwind"
+
+RDEPEND="
+ dev-cpp/gflags:=
+ dev-cpp/glog:=[gflags]
+ dev-cpp/folly:=
+ llvm-libunwind? ( sys-libs/llvm-libunwind:= )
+ !llvm-libunwind? ( sys-libs/libunwind:= )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-cpp/gtest
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_DIR="$(get_libdir)/cmake/${PN}"
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+
+ cmake_src_configure
+}
diff --git a/dev-cpp/edencommon/metadata.xml b/dev-cpp/edencommon/metadata.xml
new file mode 100644
index 000000000000..ee7565d560cc
--- /dev/null
+++ b/dev-cpp/edencommon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sam@gentoo.org</email>
+ <name>Sam James</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">facebookexperimental/edencommon</remote-id>
+ </upstream>
+</pkgmetadata>