summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/glog/glog-0.4.0.ebuild')
-rw-r--r--dev-cpp/glog/glog-0.4.0.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-cpp/glog/glog-0.4.0.ebuild b/dev-cpp/glog/glog-0.4.0.ebuild
index c5097b33e782..9b10f2e2fc95 100644
--- a/dev-cpp/glog/glog-0.4.0.ebuild
+++ b/dev-cpp/glog/glog-0.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 2011-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
@@ -11,11 +11,13 @@ SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs test"
+# -sparc as libunwind is not ported on sparc
+KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 -sparc x86 ~amd64-linux ~x86-linux"
+IUSE="gflags static-libs test"
RESTRICT="test"
-RDEPENDS="sys-libs/libunwind[${MULTILIB_USEDEP}]"
+RDEPEND="sys-libs/libunwind[${MULTILIB_USEDEP}]
+ gflags? ( dev-cpp/gflags[${MULTILIB_USEDEP}] )"
DEPEND="${RDEPEND}
test? ( >=dev-cpp/gtest-1.8.0[${MULTILIB_USEDEP}] )"
@@ -32,7 +34,8 @@ src_prepare() {
multilib_src_configure() {
ECONF_SOURCE="${S}" econf \
- $(use_enable static-libs static)
+ $(use_enable static-libs static) \
+ ac_cv_lib_gflags_main="$(usex gflags)"
}
multilib_src_install_all() {