summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/gtest')
-rw-r--r--dev-cpp/gtest/Manifest4
-rw-r--r--dev-cpp/gtest/files/gtest-1.10.0_p20200702-increase-clone-stack-size.patch14
-rw-r--r--dev-cpp/gtest/gtest-1.13.0.ebuild (renamed from dev-cpp/gtest/gtest-1.11.0.ebuild)19
-rw-r--r--dev-cpp/gtest/gtest-1.14.0.ebuild (renamed from dev-cpp/gtest/gtest-1.12.1.ebuild)20
-rw-r--r--dev-cpp/gtest/gtest-9999.ebuild22
5 files changed, 27 insertions, 52 deletions
diff --git a/dev-cpp/gtest/Manifest b/dev-cpp/gtest/Manifest
index 3aff3c058b8f..8f44d5904099 100644
--- a/dev-cpp/gtest/Manifest
+++ b/dev-cpp/gtest/Manifest
@@ -1,2 +1,2 @@
-DIST gtest-1.11.0.tar.gz 886330 BLAKE2B d11fdd485f292d96508cbc27a9a444ab69b86571cc594298fd3f0e6d4bd8d6ec20dea848fe11be165d34054b2251ad377f0930f852914feaa1416ff156986a9c SHA512 6fcc7827e4c4d95e3ae643dd65e6c4fc0e3d04e1778b84f6e06e390410fe3d18026c131d828d949d2f20dde6327d30ecee24dcd3ef919e21c91e010d149f3a28
-DIST gtest-1.12.1.tar.gz 854944 BLAKE2B 7b121fb95bb19efec1387a83da2201a139197225f79f7649ceac04695ff06fc4148319ae928d79ced413a9cfd42e68b56bfda1ee6bfdbf07fdd22795e9974388 SHA512 a9104dc6c53747e36e7dd7bb93dfce51a558bd31b487a9ef08def095518e1296da140e0db263e0644d9055dbd903c0cb69380cb2322941dbfb04780ef247df9c
+DIST gtest-1.13.0.tar.gz 862871 BLAKE2B d2768332c233d62f7a5f5332b63dc587c96c24765b2eeaa4f4caf5d421b175aa850d81cec4f50eeef9e06d4b86cb959555b4c2862a197ce3cb86d61fcb51f5d1 SHA512 70c0cfb1b4147bdecb467ecb22ae5b5529eec0abc085763213a796b7cdbd81d1761d12b342060539b936fa54f345d33f060601544874d6213fdde79111fa813e
+DIST gtest-1.14.0.tar.gz 867764 BLAKE2B c457f55ac572b9fb1553eee3df7eeeaf1e7dd2c3d747dd5e90dd279038fa5c71bb7b7d9ba1cf7e6143898b2a1d24d100584bd2a48ded41a426870c4825eec1b2 SHA512 765c326ccc1b87a01027385e69238266e356361cd4ee3e18e3c9d137a5d11fa5d657c164d02dd1be8fe693c8e10f2b580588dbfa57d27f070e2750f50d3e662c
diff --git a/dev-cpp/gtest/files/gtest-1.10.0_p20200702-increase-clone-stack-size.patch b/dev-cpp/gtest/files/gtest-1.10.0_p20200702-increase-clone-stack-size.patch
deleted file mode 100644
index 0c47681ba347..000000000000
--- a/dev-cpp/gtest/files/gtest-1.10.0_p20200702-increase-clone-stack-size.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Bug: https://bugs.gentoo.org/692464
- https://bugs.gentoo.org/834068
-
---- a/googletest/src/gtest-death-test.cc
-+++ b/googletest/src/gtest-death-test.cc
-@@ -1070,7 +1070,7 @@
-
- if (!use_fork) {
- static const bool stack_grows_down = StackGrowsDown();
-- const auto stack_size = static_cast<size_t>(getpagesize() * 2);
-+ const auto stack_size = static_cast<size_t>(getpagesize() * 12);
- // MMAP_ANONYMOUS is not defined on Mac, so we use MAP_ANON instead.
- void* const stack = mmap(NULL, stack_size, PROT_READ | PROT_WRITE,
- MAP_ANON | MAP_PRIVATE, -1, 0);
diff --git a/dev-cpp/gtest/gtest-1.11.0.ebuild b/dev-cpp/gtest/gtest-1.13.0.ebuild
index 78623e8917a1..6ed984c01511 100644
--- a/dev-cpp/gtest/gtest-1.11.0.ebuild
+++ b/dev-cpp/gtest/gtest-1.13.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit cmake-multilib python-any-r1
@@ -13,15 +13,15 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/google/googletest"
else
if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- SRC_URI="https://github.com/google/googletest/archive/refs/tags/release-${PV}.tar.gz
+ SRC_URI="https://github.com/google/googletest/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/googletest-release-${PV}
+ S="${WORKDIR}"/googletest-${PV}
else
SRC_URI="https://github.com/google/googletest/archive/${GOOGLETEST_COMMIT}.tar.gz
-> ${P}.tar.gz"
S="${WORKDIR}"/googletest-${GOOGLETEST_COMMIT}
fi
- KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="Google C++ Testing Framework"
@@ -34,10 +34,6 @@ RESTRICT="!test? ( test )"
BDEPEND="test? ( ${PYTHON_DEPS} )"
-PATCHES=(
- "${FILESDIR}"/${PN}-1.10.0_p20200702-increase-clone-stack-size.patch
-)
-
pkg_setup() {
use test && python-any-r1_pkg_setup
}
@@ -62,6 +58,11 @@ multilib_src_configure() {
cmake_src_configure
}
+multilib_src_test() {
+ # Exclude tests that fail with FEATURES="usersandbox"
+ cmake_src_test -E "googletest-(death-test|port)-test"
+}
+
multilib_src_install_all() {
einstalldocs
diff --git a/dev-cpp/gtest/gtest-1.12.1.ebuild b/dev-cpp/gtest/gtest-1.14.0.ebuild
index 68ce123507cb..db197bf961d2 100644
--- a/dev-cpp/gtest/gtest-1.12.1.ebuild
+++ b/dev-cpp/gtest/gtest-1.14.0.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake-multilib python-any-r1
@@ -13,15 +13,15 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/google/googletest"
else
if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- SRC_URI="https://github.com/google/googletest/archive/refs/tags/release-${PV}.tar.gz
+ SRC_URI="https://github.com/google/googletest/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/googletest-release-${PV}
+ S="${WORKDIR}"/googletest-${PV}
else
SRC_URI="https://github.com/google/googletest/archive/${GOOGLETEST_COMMIT}.tar.gz
-> ${P}.tar.gz"
S="${WORKDIR}"/googletest-${GOOGLETEST_COMMIT}
fi
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="Google C++ Testing Framework"
@@ -38,13 +38,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- cmake_src_prepare
-
- sed -i -e '/set(cxx_base_flags /s:-Werror::' \
- googletest/cmake/internal_utils.cmake || die "sed failed!"
-}
-
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_GMOCK=ON
@@ -53,8 +46,9 @@ multilib_src_configure() {
# tests
-Dgmock_build_tests=$(usex test)
-Dgtest_build_tests=$(usex test)
- -DPYTHON_EXECUTABLE="${PYTHON}"
)
+ use test && mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
+
cmake_src_configure
}
diff --git a/dev-cpp/gtest/gtest-9999.ebuild b/dev-cpp/gtest/gtest-9999.ebuild
index 0895416d2312..5351c69b1cd0 100644
--- a/dev-cpp/gtest/gtest-9999.ebuild
+++ b/dev-cpp/gtest/gtest-9999.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Python is required for tests and some build tasks.
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit cmake-multilib python-any-r1
@@ -13,15 +13,15 @@ if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/google/googletest"
else
if [[ -z ${GOOGLETEST_COMMIT} ]]; then
- SRC_URI="https://github.com/google/googletest/archive/refs/tags/release-${PV}.tar.gz
+ SRC_URI="https://github.com/google/googletest/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"
- S="${WORKDIR}"/googletest-release-${PV}
+ S="${WORKDIR}"/googletest-${PV}
else
SRC_URI="https://github.com/google/googletest/archive/${GOOGLETEST_COMMIT}.tar.gz
-> ${P}.tar.gz"
S="${WORKDIR}"/googletest-${GOOGLETEST_COMMIT}
fi
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
fi
DESCRIPTION="Google C++ Testing Framework"
@@ -38,13 +38,6 @@ pkg_setup() {
use test && python-any-r1_pkg_setup
}
-src_prepare() {
- cmake_src_prepare
-
- sed -i -e '/set(cxx_base_flags /s:-Werror::' \
- googletest/cmake/internal_utils.cmake || die "sed failed!"
-}
-
multilib_src_configure() {
local mycmakeargs=(
-DBUILD_GMOCK=ON
@@ -53,14 +46,15 @@ multilib_src_configure() {
# tests
-Dgmock_build_tests=$(usex test)
-Dgtest_build_tests=$(usex test)
- -DPYTHON_EXECUTABLE="${PYTHON}"
)
+ use test && mycmakeargs+=( -DPython3_EXECUTABLE="${PYTHON}" )
+
cmake_src_configure
}
multilib_src_test() {
# Exclude tests that fail with FEATURES="usersandbox"
- cmake_src_test -E "googletest-death-test-test"
+ cmake_src_test -E "googletest-(death-test|port)-test"
}
multilib_src_install_all() {