summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/json11/json11-1.0.0-r1.ebuild')
-rw-r--r--dev-cpp/json11/json11-1.0.0-r1.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-cpp/json11/json11-1.0.0-r1.ebuild b/dev-cpp/json11/json11-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..ab8457f641aa
--- /dev/null
+++ b/dev-cpp/json11/json11-1.0.0-r1.ebuild
@@ -0,0 +1,19 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A tiny JSON library for C++11"
+HOMEPAGE="https://github.com/dropbox/json11"
+SRC_URI="https://github.com/dropbox/json11/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-fix-multiarch-install.patch
+ "${FILESDIR}"/${PN}-1.0.0-json11.pc-do-not-state-the-defaults.patch
+)