summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libglademm')
-rw-r--r--dev-cpp/libglademm/Manifest1
-rw-r--r--dev-cpp/libglademm/libglademm-2.6.7-r1.ebuild78
-rw-r--r--dev-cpp/libglademm/libglademm-2.6.7.ebuild62
-rw-r--r--dev-cpp/libglademm/metadata.xml5
4 files changed, 146 insertions, 0 deletions
diff --git a/dev-cpp/libglademm/Manifest b/dev-cpp/libglademm/Manifest
new file mode 100644
index 000000000000..d77e6f95e3e4
--- /dev/null
+++ b/dev-cpp/libglademm/Manifest
@@ -0,0 +1 @@
+DIST libglademm-2.6.7.tar.bz2 326385 SHA256 38543c15acf727434341cc08c2b003d24f36abc22380937707fc2c5c687a2bc3 SHA512 d7042d0549df9322d3202d5c0733d65b153a8ff451bb9e401b9d93a915ec4c2c086428e4febcbae2ecec5936955b7afbc59beff93d492f23b7b8e2b19fe806b0 WHIRLPOOL a25ae3601df4ba201f1b5aeeca9f5527cd804d9481ef7795f651096419833d8a3cbab53d731ac2464ed20b85110d3003011a7fb2ea87e227ad75d301f5317df9
diff --git a/dev-cpp/libglademm/libglademm-2.6.7-r1.ebuild b/dev-cpp/libglademm/libglademm-2.6.7-r1.ebuild
new file mode 100644
index 000000000000..61a115943621
--- /dev/null
+++ b/dev-cpp/libglademm/libglademm-2.6.7-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2 multilib-minimal
+
+DESCRIPTION="C++ bindings for libglade"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
+IUSE="doc examples"
+
+COMMON_DEPEND="
+ >=gnome-base/libglade-2.6.4-r1:2.0[${MULTILIB_USEDEP}]
+ >=dev-cpp/gtkmm-2.24.3:2.4[${MULTILIB_USEDEP}]
+ >=dev-cpp/glibmm-2.34.1:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ abi_x86_32? (
+ !<=app-emulation/emul-linux-x86-gtkmmlibs-20140508
+ !app-emulation/emul-linux-x86-gtkmmlibs[-abi_x86_32(-)] )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # we will control install manually in install
+ sed -i 's/^\(SUBDIRS =.*\)docs\(.*\)$/\1\2/' Makefile.am Makefile.in || \
+ die "sed Makefile.{am,in} failed (1)"
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ Makefile.am Makefile.in || die "sed Makefile.{am,in} failed (2)"
+
+ gnome2_src_prepare
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" gnome2_src_configure
+}
+
+multilib_src_compile() {
+ gnome2_src_compile
+
+ if multilib_is_native_abi && use doc; then
+ emake -C "docs/reference" all || die "emake doc failed"
+ fi
+}
+
+multilib_src_install() {
+ gnome2_src_install
+
+ if use examples; then
+ emake -C "examples" distclean || die "examples clean up failed"
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+
+ if use examples; then
+ find "${S}/examples" -name "Makefile*" -delete \
+ || die "examples cleanup failed"
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "doins failed"
+ fi
+}
diff --git a/dev-cpp/libglademm/libglademm-2.6.7.ebuild b/dev-cpp/libglademm/libglademm-2.6.7.ebuild
new file mode 100644
index 000000000000..7d3d9dab3146
--- /dev/null
+++ b/dev-cpp/libglademm/libglademm-2.6.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for libglade"
+HOMEPAGE="http://www.gtkmm.org"
+
+LICENSE="LGPL-2.1+"
+SLOT="2.4"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND="
+ >=gnome-base/libglade-2.6.1:2.0
+ >=dev-cpp/gtkmm-2.6:2.4
+ >=dev-cpp/glibmm-2.4:2
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # we will control install manually in install
+ sed -i 's/^\(SUBDIRS =.*\)docs\(.*\)$/\1\2/' Makefile.am Makefile.in || \
+ die "sed Makefile.{am,in} failed (1)"
+
+ # don't waste time building the examples
+ sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' \
+ Makefile.am Makefile.in || die "sed Makefile.{am,in} failed (2)"
+
+ gnome2_src_prepare
+}
+
+src_compile() {
+ gnome2_src_compile
+
+ if use doc; then
+ emake -C "${S}/docs/reference" all || die "emake doc failed"
+ fi
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use doc ; then
+ dohtml -r docs/reference/html/*
+ fi
+
+ if use examples; then
+ emake -C "${S}/examples" distclean || die "examples clean up failed"
+ find "${S}/examples" -name "Makefile*" -delete \
+ || die "examples cleanup failed"
+ insinto "/usr/share/doc/${PF}"
+ doins -r examples || die "doins failed"
+ fi
+}
diff --git a/dev-cpp/libglademm/metadata.xml b/dev-cpp/libglademm/metadata.xml
new file mode 100644
index 000000000000..57c9d9c1a1d8
--- /dev/null
+++ b/dev-cpp/libglademm/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome-mm</herd>
+</pkgmetadata>