summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/lucene++/files')
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch13
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch42
-rw-r--r--dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch39
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch
deleted file mode 100644
index ba5deca413c8..000000000000
--- a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-demos.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 9217c21..d4e7b86 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -118,7 +118,7 @@ enable_testing()
-
- add_subdirectory(src/core)
- add_subdirectory(src/contrib)
--add_subdirectory(src/demo)
-+#add_subdirectory(src/demo)
- add_subdirectory(src/test)
-
- #################################
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch
deleted file mode 100644
index 1fae17e71d30..000000000000
--- a/dev-cpp/lucene++/files/lucene++-3.0.6-disable-tests.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-Forwarded: https://github.com/luceneplusplus/LucenePlusPlus/pull/64
-Author: Gianfranco Costamagna <costamagnagianfranco@yahoo.it>
-Description: Disabling tests until we find a proper way for building and including gtest
- In the next release this might become possible, after commit 83356d9681fb52
- https://github.com/luceneplusplus/LucenePlusPlus/commit/83356d9681fb52a4c190d2cf033279006c1bf57d
-Last-Update: 2014-08-25
---- a/CMakeExternal.txt
-+++ b/CMakeExternal.txt
-@@ -1,5 +1,6 @@
- # Enable ExternalProject CMake module
- include(ExternalProject)
-+find_package(Subversion REQUIRED)
-
- # main directory for external projects
- set_directory_properties(PROPERTIES EP_PREFIX ${CMAKE_CURRENT_BINARY_DIR}/ThirdParty)
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -49,7 +49,6 @@
- # bootstrap
- ####################################
-
--find_package(Subversion REQUIRED)
- find_package(Threads REQUIRED)
- find_package(Boost COMPONENTS
- date_time
-@@ -114,13 +113,13 @@
- ${CMAKE_CURRENT_BINARY_DIR}/include
- )
-
--include(CMakeExternal.txt)
--enable_testing()
-+#include(CMakeExternal.txt)
-+#enable_testing()
-
- add_subdirectory(src/core)
- add_subdirectory(src/contrib)
- #add_subdirectory(src/demo)
--add_subdirectory(src/test)
-+#add_subdirectory(src/test)
-
- #################################
- # install pkg-config file
diff --git a/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch b/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch
deleted file mode 100644
index f9ccc84eccd3..000000000000
--- a/dev-cpp/lucene++/files/lucene++-3.0.6-fix-installing-headers.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From: rezso <rezso@example.com>
-Date: Mon, 19 May 2014 09:20:40 +0100
-Subject: [PATCH] fix installing lucene++ headers in 3.0.6
-
-Origin: upstream, https://github.com/luceneplusplus/LucenePlusPlus/commit/994f03cf736229044a168835ae7387696041658f
-Description: backport upstream patch to fix missing headers install
-
-Index: lucene++-3.0.6/CMakeLists.txt
-===================================================================
---- lucene++-3.0.6.orig/CMakeLists.txt
-+++ lucene++-3.0.6/CMakeLists.txt
-@@ -139,6 +139,14 @@ if(NOT WIN32)
- DESTINATION ${LIB_DESTINATION}/pkgconfig)
- endif()
-
-+#################################
-+# install Config.h
-+#################################
-+install(
-+ FILES
-+ "${CMAKE_CURRENT_BINARY_DIR}/include/Config.h"
-+ DESTINATION include/lucene++)
-+
- ####################################
- # custom targets
- ####################################
-Index: lucene++-3.0.6/src/core/CMakeLists.txt
-===================================================================
---- lucene++-3.0.6.orig/src/core/CMakeLists.txt
-+++ lucene++-3.0.6/src/core/CMakeLists.txt
-@@ -20,7 +20,7 @@ file(GLOB_RECURSE lucene_internal_header
- )
-
- file(GLOB_RECURSE lucene_headers
-- include/*.h
-+ "${lucene++_SOURCE_DIR}/include/*.h"
- )
-
- add_definitions(-DLPP_BUILDING_LIB)