summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/muParserX')
-rw-r--r--dev-cpp/muParserX/Manifest1
-rw-r--r--dev-cpp/muParserX/metadata.xml23
-rw-r--r--dev-cpp/muParserX/muParserX-4.0.11.ebuild16
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-cpp/muParserX/Manifest b/dev-cpp/muParserX/Manifest
new file mode 100644
index 000000000000..815473a36ead
--- /dev/null
+++ b/dev-cpp/muParserX/Manifest
@@ -0,0 +1 @@
+DIST muParserX-4.0.11.tar.gz 215824 BLAKE2B f077fee44d4b67b02a0c559ce492b27107b0f5294eca7266e968c852e1e2503a4f5fc4d32b07e5c6ebca8ab95d7f30cdacd257439f70a7943c5ad22d111139c9 SHA512 67846a91b57e41731a656cfee68effdd9166e738108764be5d3080854d8a01bedbeacaaade7bee11c6b5f83019abddeca3b2c9acdfbb48629da6d9b92c79c7af
diff --git a/dev-cpp/muParserX/metadata.xml b/dev-cpp/muParserX/metadata.xml
new file mode 100644
index 000000000000..e7ba537d792e
--- /dev/null
+++ b/dev-cpp/muParserX/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- comaintainers-welcomed -->
+ <maintainer type="person" proxied="yes">
+ <email>gaboroszkar@protonmail.com</email>
+ <name>Gábor Oszkár Dénes</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci@gentoo.org</email>
+ <name>Gentoo Science Project</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription>
+ The evaluation of a mathematical expression is a standard task required in many applications. It can be solved by either using a standard math expression parser such as muparser or by embedding a scripting language such as Lua. There are however some limitations: Although muparser is pretty fast it will only work with scalar values and although Lua is very flexible it does neither support binary operators for arrays nor complex numbers. So if you need a math expression parser with support for arrays, matrices and strings muparserx may be able to help you.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">beltoforion/muparserx</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-cpp/muParserX/muParserX-4.0.11.ebuild b/dev-cpp/muParserX/muParserX-4.0.11.ebuild
new file mode 100644
index 000000000000..373e92ac6637
--- /dev/null
+++ b/dev-cpp/muParserX/muParserX-4.0.11.ebuild
@@ -0,0 +1,16 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="Parsing Expressions with Strings, Complex Numbers, Vectors, Matrices and more"
+HOMEPAGE="https://beltoforion.de/en/muparser/"
+SRC_URI="https://github.com/beltoforion/muparserx/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+S="${WORKDIR}"/muparserx-${PV}