summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/pystring/pystring-1.1.3-r1.ebuild')
-rw-r--r--dev-cpp/pystring/pystring-1.1.3-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-cpp/pystring/pystring-1.1.3-r1.ebuild b/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..28892a5737ca
--- /dev/null
+++ b/dev-cpp/pystring/pystring-1.1.3-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 2020-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="C++ functions matching the interface and behavior of python string methods"
+HOMEPAGE="https://github.com/imageworks/pystring"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/imageworks/pystring.git"
+else
+ SRC_URI="https://github.com/imageworks/pystring/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+BDEPEND="dev-build/libtool"
+
+PATCHES=(
+ # Patch to convert the project into cmake. Taken from:
+ # https://github.com/imageworks/pystring/pull/29
+ "${FILESDIR}/cmake.patch"
+)