summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/random123/random123-1.14.0.ebuild')
-rw-r--r--dev-cpp/random123/random123-1.14.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/random123/random123-1.14.0.ebuild b/dev-cpp/random123/random123-1.14.0.ebuild
new file mode 100644
index 000000000000..038445dfd04e
--- /dev/null
+++ b/dev-cpp/random123/random123-1.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="library of counter-based random number generators (CBRNGs)"
+HOMEPAGE="https://www.deshawresearch.com/resources_random123.html"
+SRC_URI="https://github.com/DEShawResearch/random123/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ tc-export CC CXX
+}
+
+src_install() {
+ insinto /usr/include/Random123
+ doins -r include/Random123
+}