summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/rttr')
-rw-r--r--dev-cpp/rttr/Manifest1
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-cmake.patch25
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-permission.patch13
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-tests.patch30
-rw-r--r--dev-cpp/rttr/files/rttr-0.9.6-werror.patch18
-rw-r--r--dev-cpp/rttr/metadata.xml10
-rw-r--r--dev-cpp/rttr/rttr-0.9.6.ebuild36
7 files changed, 0 insertions, 133 deletions
diff --git a/dev-cpp/rttr/Manifest b/dev-cpp/rttr/Manifest
deleted file mode 100644
index 88fa670091c1..000000000000
--- a/dev-cpp/rttr/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST rttr-0.9.6-src.tar.gz 1137269 BLAKE2B 53bb4ed75e20a82d2bd2e6c5667efe1ba6b6f2d8a83a3bd486870daeae57a36cdcb9f2acb6d47a6d1b2f36f00a262170efa4e321f6e7faf8d2c35c431bf47133 SHA512 7e0d4fa87f83feda0b926d4d0e52aaf0f369f25fe7e23e5ffe86c0bba159e8353cef44eed37611a81e8ccc8d6facb36942f940d0d0b965f873177d7078f91cf4
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-cmake.patch b/dev-cpp/rttr/files/rttr-0.9.6-cmake.patch
deleted file mode 100644
index e313014d70a5..000000000000
--- a/dev-cpp/rttr/files/rttr-0.9.6-cmake.patch
+++ /dev/null
@@ -1,25 +0,0 @@
-Install cmake files to the correct directory.
-
-Avoid installing docs to the wrong directory (will be installed by the ebuild instead).
-
---- a/CMake/config.cmake
-+++ b/CMake/config.cmake
-@@ -69,7 +69,7 @@
-
- set(RTTR_INSTALL_FULL_LIBDIR "${CMAKE_INSTALL_FULL_LIBDIR}")
-
-- set(RTTR_CMAKE_CONFIG_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/rttr/cmake")
-+ set(RTTR_CMAKE_CONFIG_INSTALL_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/rttr")
- set(RTTR_ADDITIONAL_FILES_INSTALL_DIR "${CMAKE_INSTALL_DATADIR}/rttr")
-
- elseif(WIN32)
-@@ -169,8 +169,4 @@
- install(FILES "${CMAKE_CURRENT_BINARY_DIR}/CMake/rttr-config-version.cmake"
- DESTINATION ${RTTR_CMAKE_CONFIG_INSTALL_DIR}
- COMPONENT Devel)
--
-- install(FILES "${LICENSE_FILE}" "${README_FILE}"
-- DESTINATION ${RTTR_ADDITIONAL_FILES_INSTALL_DIR}
-- PERMISSIONS OWNER_READ)
- endif()
-
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-permission.patch b/dev-cpp/rttr/files/rttr-0.9.6-permission.patch
deleted file mode 100644
index bec7ac36bfc9..000000000000
--- a/dev-cpp/rttr/files/rttr-0.9.6-permission.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-Avoid installing headers with mode 700.
-
---- a/CMake/utility.cmake
-+++ b/CMake/utility.cmake
-@@ -165,7 +165,7 @@
- getNameOfDir(CMAKE_CURRENT_SOURCE_DIR DIRNAME)
- if (${shouldInstall})
- if (NOT ${FULL_HEADER_PATH} MATCHES ".*_p.h$") # we don't want to install header files which are marked as private
-- install(FILES ${FULL_HEADER_PATH} DESTINATION "include/${DIRNAME}/${REL_PATH}" PERMISSIONS OWNER_READ)
-+ install(FILES ${FULL_HEADER_PATH} DESTINATION "include/${DIRNAME}/${REL_PATH}")
- endif()
- endif()
- endforeach()
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-tests.patch b/dev-cpp/rttr/files/rttr-0.9.6-tests.patch
deleted file mode 100644
index bd966c3d327d..000000000000
--- a/dev-cpp/rttr/files/rttr-0.9.6-tests.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-Avoid running a custom testsuite unconditionally.
-
---- a/src/unit_tests/CMakeLists.txt
-+++ b/src/unit_tests/CMakeLists.txt
-@@ -54,17 +54,17 @@
- endif()
-
- # run tests
--add_custom_target(run_tests ALL
-- COMMAND "$<TARGET_FILE:unit_tests>"
-- DEPENDS unit_tests
-- COMMENT "Running unit_tests")
-+#add_custom_target(run_tests ALL
-+# COMMAND "$<TARGET_FILE:unit_tests>"
-+# DEPENDS unit_tests
-+# COMMENT "Running unit_tests")
-
--set_target_properties(run_tests PROPERTIES
-- FOLDER "Testing")
-+#set_target_properties(run_tests PROPERTIES
-+# FOLDER "Testing")
-
- add_subdirectory(plugin)
-
- add_dependencies(unit_tests unit_test_plugin)
-
- message(STATUS "Scanning " ${PROJECT_NAME} " module finished!")
--message(STATUS "")
-\ No newline at end of file
-+message(STATUS "")
diff --git a/dev-cpp/rttr/files/rttr-0.9.6-werror.patch b/dev-cpp/rttr/files/rttr-0.9.6-werror.patch
deleted file mode 100644
index 04c65203ac91..000000000000
--- a/dev-cpp/rttr/files/rttr-0.9.6-werror.patch
+++ /dev/null
@@ -1,18 +0,0 @@
-This causes build failures with modern GCC, and is against Gentoo policy in any case.
-
---- a/CMake/utility.cmake
-+++ b/CMake/utility.cmake
-@@ -392,11 +392,9 @@
- ####################################################################################
- function( set_compiler_warnings target)
- if(CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
-- set(WARNINGS "-Werror"
-- "-Wall")
-+ set(WARNINGS "-Wall")
- elseif(CMAKE_CXX_COMPILER_ID MATCHES "Clang")
-- set(WARNINGS "-Werror"
-- "-Wall")
-+ set(WARNINGS "-Wall")
- elseif(MSVC)
- set(WARNINGS "/WX"
- "/W4")
diff --git a/dev-cpp/rttr/metadata.xml b/dev-cpp/rttr/metadata.xml
deleted file mode 100644
index 2fb187146ee7..000000000000
--- a/dev-cpp/rttr/metadata.xml
+++ /dev/null
@@ -1,10 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>kde@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">rttrorg/rttr</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-cpp/rttr/rttr-0.9.6.ebuild b/dev-cpp/rttr/rttr-0.9.6.ebuild
deleted file mode 100644
index 68f6af176d78..000000000000
--- a/dev-cpp/rttr/rttr-0.9.6.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit cmake-utils
-
-DESCRIPTION="Run Time Type Reflection - library adding reflection to C++"
-HOMEPAGE="https://www.rttr.org/"
-SRC_URI="https://github.com/rttrorg/${PN}/releases/download/v${PV}/${P}-src.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm64 x86"
-IUSE=""
-
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}-cmake.patch"
- "${FILESDIR}/${P}-permission.patch"
- "${FILESDIR}/${P}-tests.patch"
- "${FILESDIR}/${P}-werror.patch"
-)
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_DOCUMENTATION=off #broken
- )
-
- cmake-utils_src_configure
-}
-
-src_test() {
- "${BUILD_DIR}"/bin/unit_tests || die
-}