summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/sparsehash/sparsehash-2.0.4.ebuild')
-rw-r--r--dev-cpp/sparsehash/sparsehash-2.0.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild b/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
new file mode 100644
index 000000000000..f2c96528a8b1
--- /dev/null
+++ b/dev-cpp/sparsehash/sparsehash-2.0.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="An extremely memory-efficient hash_map implementation"
+HOMEPAGE="https://github.com/sparsehash/sparsehash"
+SRC_URI="https://github.com/sparsehash/sparsehash/archive/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 x86 ~amd64-linux ~x86-linux"
+
+S="${WORKDIR}/${PN}-${P}"
+
+PATCHES=( "${FILESDIR}"/${PN}-2.0.3-fix-buildsystem.patch )
+
+src_prepare() {
+ default
+ eautoreconf
+}