summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/tree')
-rw-r--r--dev-cpp/tree/Manifest3
-rw-r--r--dev-cpp/tree/files/tree-2.62-test.patch17
-rw-r--r--dev-cpp/tree/metadata.xml5
-rw-r--r--dev-cpp/tree/tree-2.81.ebuild41
-rw-r--r--dev-cpp/tree/tree-3.17.ebuild39
-rw-r--r--dev-cpp/tree/tree-3.18.ebuild39
6 files changed, 84 insertions, 60 deletions
diff --git a/dev-cpp/tree/Manifest b/dev-cpp/tree/Manifest
index c6030dad7492..b7bf3066bc41 100644
--- a/dev-cpp/tree/Manifest
+++ b/dev-cpp/tree/Manifest
@@ -1 +1,2 @@
-DIST tree-2.81.tar.gz 1167128 BLAKE2B ea92724b16fc7ea8a5f0036f5a7a57d000d66b332b4ba46139463f707f95922f38b1d4d56a6d2fca0a3c4ece8f11e28bbf4aa6bec5c5a7bc59ccaa36a01413d6 SHA512 85e910fdb19ffd03ae79302a95ebffdb44725fd9f291a61d6912f743b54fe9b3d1c863e00c7e75d238f428946809e42c7ae6379b1051688fb06ee6c6d761d294
+DIST tree-3.17.tar.gz 1178425 BLAKE2B f59239b861c0495c48036d0fffa49370d4cd78a94bfc35348bbbe0232a3c1221293a23366a6289429adabcb00b21292288ce085fa54f74dc204537c95c5b7c37 SHA512 af11f693c13dd37dddf016751c0f975c21d7a5ad405879e18fbe5387400ee1fcfb42942ee8888efffcb0c985d7875f2698591139aeb18b4809e83e225a743112
+DIST tree-3.18.tar.gz 1179107 BLAKE2B d05f90c58e203800a7482d0d7b36625dc32e9d3321a65f80fda380d2d7c214be1f47bc01d9f20fe2e287eeafdebe4180940ba7dbc7f78c12072193cbb95c2df1 SHA512 df9047fcd92ac5137af47dd03582fa1ba87651f112a91a1d61eecf3916af1a2130e1841e954af9b6eeb167da33c9e50c2662ecdcc5317e67173ba50f77afeae0
diff --git a/dev-cpp/tree/files/tree-2.62-test.patch b/dev-cpp/tree/files/tree-2.62-test.patch
deleted file mode 100644
index f7022426698b..000000000000
--- a/dev-cpp/tree/files/tree-2.62-test.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- test_tree.output 2008-08-28 11:16:11.000000000 +0100
-+++ test_tree.output.new 2009-04-15 19:06:53.174832287 +0100
-@@ -1,3 +1,8 @@
-+-----
-+hi
-+ 1
-+ 0
-+-----
- empty tree to begin with:
- 0
- 'more text' is sibling 2 in its sibling range
-@@ -309,3 +314,5 @@
- D
- I
- -----
-+G
-+H
diff --git a/dev-cpp/tree/metadata.xml b/dev-cpp/tree/metadata.xml
index f6bb7c0c19ad..9a339da1603b 100644
--- a/dev-cpp/tree/metadata.xml
+++ b/dev-cpp/tree/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci@gentoo.org</email>
@@ -12,4 +12,7 @@
others). Where possible the access methods are compatible with the
STL or alternative algorithms are available.
</longdescription>
+ <upstream>
+ <remote-id type="github">kpeeters/tree.hh</remote-id>
+ </upstream>
</pkgmetadata>
diff --git a/dev-cpp/tree/tree-2.81.ebuild b/dev-cpp/tree/tree-2.81.ebuild
deleted file mode 100644
index db3b12d49646..000000000000
--- a/dev-cpp/tree/tree-2.81.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=4
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="An STL-like tree class"
-HOMEPAGE="http://www.aei.mpg.de/~peekas/tree/"
-SRC_URI="http://www.aei.mpg.de/~peekas/tree/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 GPL-3 )"
-SLOT="0"
-KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-S="${S}"/src
-
-src_prepare() {
- rm Makefile || die
- epatch "${FILESDIR}"/${PN}-2.62-test.patch
-}
-
-src_test() {
- local test
- test="$(tc-getCXX) ${CXXFLAGS} ${LDAFLAGS} test_tree.cc -o test_tree"
-
- echo ${test}
- eval ${test} || die "compile test failed"
- ./test_tree > mytest.output || die "running test failed"
- diff -Nu test_tree.output mytest.output || die "test dist failed"
-}
-
-src_install() {
- insinto /usr/include
- doins tree.hh tree_util.hh
- dodoc tree_example.cc
- if use doc; then
- dohtml "${S}"/../doc/*
- fi
-}
diff --git a/dev-cpp/tree/tree-3.17.ebuild b/dev-cpp/tree/tree-3.17.ebuild
new file mode 100644
index 000000000000..725e4cac0b55
--- /dev/null
+++ b/dev-cpp/tree/tree-3.17.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DOCS_BUILDER="doxygen"
+DOCS_CONFIG_NAME="doxygen_tree.config"
+DOCS_DIR="doc"
+
+inherit docs toolchain-funcs
+
+DESCRIPTION="An STL-like tree class"
+HOMEPAGE="https://github.com/kpeeters/tree.hh"
+SRC_URI="https://github.com/kpeeters/tree.hh/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.hh-${PV}"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="amd64 ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ docs_compile
+}
+
+src_test() {
+ cd src || die
+ emake
+ emake run_tests
+}
+
+src_install() {
+ doheader src/tree.hh src/tree_util.hh
+ dodoc -r examples
+ einstalldocs
+}
diff --git a/dev-cpp/tree/tree-3.18.ebuild b/dev-cpp/tree/tree-3.18.ebuild
new file mode 100644
index 000000000000..33b480f4a325
--- /dev/null
+++ b/dev-cpp/tree/tree-3.18.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DOCS_BUILDER="doxygen"
+DOCS_CONFIG_NAME="doxygen_tree.config"
+DOCS_DIR="doc"
+
+inherit docs toolchain-funcs
+
+DESCRIPTION="An STL-like tree class"
+HOMEPAGE="https://github.com/kpeeters/tree.hh"
+SRC_URI="https://github.com/kpeeters/tree.hh/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}.hh-${PV}"
+
+LICENSE="|| ( GPL-2 GPL-3 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+src_configure() {
+ tc-export CXX
+}
+
+src_compile() {
+ docs_compile
+}
+
+src_test() {
+ cd src || die
+ emake
+ emake run_tests
+}
+
+src_install() {
+ doheader src/tree.hh src/tree_util.hh
+ dodoc -r examples
+ einstalldocs
+}