summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild')
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild9
1 files changed, 5 insertions, 4 deletions
diff --git a/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
index 4578afc07baa..16030b37783e 100644
--- a/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
+++ b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
DESCRIPTION="C++/Boost Asio based websocket client/server library"
HOMEPAGE="https://www.zaphoyd.com/websocketpp"
@@ -31,11 +31,12 @@ src_configure() {
-DENABLE_CPP11=ON
-DBUILD_TESTS="$(usex test)"
)
- cmake-utils_src_configure
+
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use examples; then
dodoc -r examples