summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/websocketpp')
-rw-r--r--dev-cpp/websocketpp/metadata.xml3
-rw-r--r--dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild (renamed from dev-cpp/websocketpp/websocketpp-0.8.1.ebuild)22
2 files changed, 12 insertions, 13 deletions
diff --git a/dev-cpp/websocketpp/metadata.xml b/dev-cpp/websocketpp/metadata.xml
index 66fe497e1c38..d930eea34f05 100644
--- a/dev-cpp/websocketpp/metadata.xml
+++ b/dev-cpp/websocketpp/metadata.xml
@@ -5,9 +5,6 @@
<email>johu@gentoo.org</email>
<name>Johannes Huber</name>
</maintainer>
- <use>
- <flag name="boost">Use <pkg>dev-libs/boost</pkg> instead of C++11</flag>
- </use>
<upstream>
<remote-id type="github">zaphoyd/websocketpp</remote-id>
</upstream>
diff --git a/dev-cpp/websocketpp/websocketpp-0.8.1.ebuild b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
index 7a4b182f57c1..4578afc07baa 100644
--- a/dev-cpp/websocketpp/websocketpp-0.8.1.ebuild
+++ b/dev-cpp/websocketpp/websocketpp-0.8.1-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit cmake-utils
@@ -9,15 +9,14 @@ DESCRIPTION="C++/Boost Asio based websocket client/server library"
HOMEPAGE="https://www.zaphoyd.com/websocketpp"
SRC_URI="https://github.com/zaphoyd/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
LICENSE="BSD"
SLOT="0"
-IUSE="boost examples test"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
-DEPEND=""
-RDEPEND="${DEPEND}
- boost? ( dev-libs/boost )
-"
+DEPEND="test? ( dev-libs/boost )"
+RDEPEND="dev-libs/boost"
PATCHES=(
"${FILESDIR}"/${PN}-0.7.0-cmake-install.patch
@@ -29,14 +28,17 @@ PATCHES=(
src_configure() {
local mycmakeargs=(
- -DENABLE_CPP11="$(usex !boost)"
+ -DENABLE_CPP11=ON
-DBUILD_TESTS="$(usex test)"
)
-
cmake-utils_src_configure
}
src_install() {
- use examples && DOCS=( examples/ )
cmake-utils_src_install
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
}