summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/catch/Manifest1
-rw-r--r--dev-cpp/catch/catch-1.5.0.ebuild39
-rw-r--r--dev-cpp/catch/catch-9999.ebuild39
-rw-r--r--dev-cpp/catch/metadata.xml11
4 files changed, 90 insertions, 0 deletions
diff --git a/dev-cpp/catch/Manifest b/dev-cpp/catch/Manifest
new file mode 100644
index 000000000000..4fb5249fef00
--- /dev/null
+++ b/dev-cpp/catch/Manifest
@@ -0,0 +1 @@
+DIST catch-1.5.0.tar.gz 311787 SHA256 f694634bc56422f28d61052eedc29d43ea20e60a1726eda3ff9acc8fdfca3c08 SHA512 d7011cdfe6eca86aa081b5da371665be8687bcbb41f3702c3075bf01f73e1d2e00894a0917e6437a8735e730ff287a06e189ce94ea00e583ab7282065f25166d WHIRLPOOL 90d7d6d2f4b06169224385e0f2ec0de1312c454a0c7a2a14155f68fe30424e527cde91e5fb4ff9bd441fa846a7caabca023e591ce5837f6c65f0bbe106166401
diff --git a/dev-cpp/catch/catch-1.5.0.ebuild b/dev-cpp/catch/catch-1.5.0.ebuild
new file mode 100644
index 000000000000..f8974412796c
--- /dev/null
+++ b/dev-cpp/catch/catch-1.5.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI="https://github.com/philsquared/Catch/archive/V${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S=${WORKDIR}/${P^}
+CMAKE_USE_DIR=${S}/projects/CMake
+
+src_configure() {
+ # CMake is only used to build & run tests
+ use test && cmake-utils_src_configure
+}
+
+src_compile() {
+ use test && cmake-utils_src_compile
+}
+
+src_test() {
+ use test && cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}
diff --git a/dev-cpp/catch/catch-9999.ebuild b/dev-cpp/catch/catch-9999.ebuild
new file mode 100644
index 000000000000..ee8fefd8da7c
--- /dev/null
+++ b/dev-cpp/catch/catch-9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+EGIT_REPO_URI="https://github.com/philsquared/Catch.git"
+inherit cmake-utils git-r3
+
+DESCRIPTION="Modern C++ header-only framework for unit-tests"
+HOMEPAGE="https://github.com/philsquared/Catch"
+SRC_URI=""
+
+LICENSE="Boost-1.0"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+
+CMAKE_USE_DIR=${S}/projects/CMake
+
+src_configure() {
+ # CMake is only used to build & run tests
+ use test && cmake-utils_src_configure
+}
+
+src_compile() {
+ use test && cmake-utils_src_compile
+}
+
+src_test() {
+ use test && cmake-utils_src_test
+}
+
+src_install() {
+ # same location as used in fedora
+ insinto /usr/include/catch
+ doins -r include/.
+ dodoc -r docs/.
+}
diff --git a/dev-cpp/catch/metadata.xml b/dev-cpp/catch/metadata.xml
new file mode 100644
index 000000000000..800b18cb7704
--- /dev/null
+++ b/dev-cpp/catch/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">philsquared/Catch</remote-id>
+ </upstream>
+</pkgmetadata>