summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/pgadmin3/pgadmin3-1.22.1.ebuild')
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.22.1.ebuild60
1 files changed, 0 insertions, 60 deletions
diff --git a/dev-db/pgadmin3/pgadmin3-1.22.1.ebuild b/dev-db/pgadmin3/pgadmin3-1.22.1.ebuild
deleted file mode 100644
index d1a2e177c1a6..000000000000
--- a/dev-db/pgadmin3/pgadmin3-1.22.1.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils multilib versionator wxwidgets
-
-DESCRIPTION="wxWidgets GUI for PostgreSQL"
-HOMEPAGE="http://www.pgadmin.org/"
-SRC_URI="mirror://postgresql/${PN}/release/v${PV}/src/${P}.tar.gz"
-
-LICENSE="POSTGRESQL"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-SLOT="0"
-IUSE="debug +databasedesigner"
-
-DEPEND="x11-libs/wxGTK:=[X,debug=]
- >=dev-db/postgresql-8.4.0:=
- >=dev-libs/libxml2-2.6.18
- >=dev-libs/libxslt-1.1"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- local pgslot=$(postgresql-config show)
-
- if [[ ${pgslot//.} < 84 ]] ; then
- eerror "PostgreSQL slot must be set to 8.4 or higher."
- eerror " postgresql-config set 8.4"
- die "PostgreSQL slot is not set to 8.4 or higher."
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}/pgadmin3-desktop.patch"
-
- epatch_user
-}
-
-src_configure() {
- WX_GTK_PV=$(best_version x11-libs/wxGTK[X,debug=])
- WX_GTK_VER=$(get_version_component_range 1-2 ${WX_GTK_PV#x11-libs/wxGTK-})
-
- need-wxwidgets unicode
-
- econf --with-wx-version=${WX_GTK_VER} \
- $(use_enable debug) \
- $(use_enable databasedesigner)
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- newicon "${S}/pgadmin/include/images/pgAdmin3.png" ${PN}.png
-
- domenu "${S}/pkg/pgadmin3.desktop"
-
- # Fixing world-writable files
- fperms -R go-w /usr/share
-}