summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/sqlcipher')
-rw-r--r--dev-db/sqlcipher/Manifest1
-rw-r--r--dev-db/sqlcipher/metadata.xml11
-rw-r--r--dev-db/sqlcipher/sqlcipher-3.3.0.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/dev-db/sqlcipher/Manifest b/dev-db/sqlcipher/Manifest
new file mode 100644
index 000000000000..0e21d044dc5b
--- /dev/null
+++ b/dev-db/sqlcipher/Manifest
@@ -0,0 +1 @@
+DIST sqlcipher-3.3.0.tar.gz 10235736 SHA256 18f5df41a9806bc8eece00fde24c85107bd4807a5ae7057f9a6188de5d8fd82a SHA512 9f24fcd25811aabe36f5e27cdfc117a02ad3578a95691e9b3b7f41ee47ee0c176243c4f35a8415a17a3828d4534aae58a1097b75a950937706b10a79f2c92c81 WHIRLPOOL 1f4bdaf9ead7e2834d1efd2612c74eb91df2bbc17dfa4d404a72db4ef837b6b7a8430da522b6ec708f8873482c2de318a3cf65aebfdc53c200cad53a4ded9e6b
diff --git a/dev-db/sqlcipher/metadata.xml b/dev-db/sqlcipher/metadata.xml
new file mode 100644
index 000000000000..0b9695f30643
--- /dev/null
+++ b/dev-db/sqlcipher/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sqlcipher/sqlcipher</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild b/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild
new file mode 100644
index 000000000000..5ecac204646e
--- /dev/null
+++ b/dev-db/sqlcipher/sqlcipher-3.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+inherit autotools-multilib flag-o-matic
+
+DESCRIPTION="Full Database Encryption for SQLite"
+HOMEPAGE="http://sqlcipher.net/"
+SRC_URI="https://github.com/sqlcipher/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="readline static-libs tcl"
+
+# Tcl is always needed by buildsystem
+RDEPEND="dev-libs/openssl:0[${MULTILIB_USEDEP}]
+ readline? ( sys-libs/readline:0[${MULTILIB_USEDEP}] )
+ tcl? ( dev-lang/tcl:=[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ dev-lang/tcl"
+
+src_prepare() {
+ append-cflags -DSQLITE_HAS_CODEC
+
+ autotools-multilib_src_prepare
+}
+
+src_configure()
+{
+ local myeconfargs=(
+ --enable-tempstore=yes
+ $(use_enable readline)
+ $(use_enable tcl)
+ )
+ autotools-multilib_src_configure
+}