summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/scratchbox2/files')
-rw-r--r--dev-embedded/scratchbox2/files/scratchbox2-2.0-as-needed.patch22
-rw-r--r--dev-embedded/scratchbox2/files/scratchbox2-2.0-gentoo.patch88
-rw-r--r--dev-embedded/scratchbox2/files/scratchbox2-2.0-glibc-2.10.patch39
-rw-r--r--dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch77
4 files changed, 226 insertions, 0 deletions
diff --git a/dev-embedded/scratchbox2/files/scratchbox2-2.0-as-needed.patch b/dev-embedded/scratchbox2/files/scratchbox2-2.0-as-needed.patch
new file mode 100644
index 000000000000..eaffc158f9f2
--- /dev/null
+++ b/dev-embedded/scratchbox2/files/scratchbox2-2.0-as-needed.patch
@@ -0,0 +1,22 @@
+diff --git a/utils/Makefile b/utils/Makefile
+index cf9b6c4..6f715d3 100644
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -6,7 +6,7 @@ $(D)/sb2-show: CFLAGS := $(CFLAGS) -Wall -W -Werror \
+ -I$(SRCDIR)/include
+
+ $(D)/sb2-show.o: preload/exported.h
+-$(D)/sb2-show: preload/libsb2.$(SHLIBEXT) $(D)/sb2-show.o
++$(D)/sb2-show: $(D)/sb2-show.o preload/libsb2.$(SHLIBEXT)
+ $(MKOUTPUTDIR)
+ $(P)LD
+ $(Q)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+@@ -25,7 +25,7 @@ $(D)/sb2-interp-wrapper: CFLAGS := $(CFLAGS) -Wall -W -Werror \
+ -I$(SRCDIR)/preload -Ipreload/ $(PROTOTYPEWARNINGS) \
+ -I$(SRCDIR)/include
+
+-$(D)/sb2-interp-wrapper: preload/libsb2.$(SHLIBEXT) $(D)/sb2-interp-wrapper.o
++$(D)/sb2-interp-wrapper: $(D)/sb2-interp-wrapper.o preload/libsb2.$(SHLIBEXT)
+ $(MKOUTPUTDIR)
+ $(P)LD
+ $(Q)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ -ldl
diff --git a/dev-embedded/scratchbox2/files/scratchbox2-2.0-gentoo.patch b/dev-embedded/scratchbox2/files/scratchbox2-2.0-gentoo.patch
new file mode 100644
index 000000000000..32dcdd1e2e36
--- /dev/null
+++ b/dev-embedded/scratchbox2/files/scratchbox2-2.0-gentoo.patch
@@ -0,0 +1,88 @@
+diff --git a/Makefile b/Makefile
+index 23a13b3..c5b26cc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -59,7 +59,6 @@ subdirs = luaif preload utils
+
+ -include config.mak
+
+-CFLAGS += -O2 -g -Wall -W
+ CFLAGS += -I$(OBJDIR)/include -I$(SRCDIR)/include
+ CFLAGS += -I$(SRCDIR)/luaif/lua-5.1.4/src
+ CFLAGS += -D_GNU_SOURCE=1 -D_LARGEFILE_SOURCE=1 -D_LARGEFILE64_SOURCE=1
+@@ -145,6 +144,9 @@ install-noarch: regular
+ else install -d -m 755 $(prefix)/share/man/man1 ; \
+ fi
+ $(Q)echo "$(PACKAGE_VERSION)" > $(prefix)/share/scratchbox2/version
++ $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-show $(prefix)/bin/sb2-show
++ $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-monitor $(prefix)/bin/sb2-monitor
++ $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-interp-wrapper $(prefix)/bin/sb2-interp-wrapper
+ $(Q)install -c -m 755 $(SRCDIR)/utils/sb2 $(prefix)/bin/sb2
+ $(Q)install -c -m 755 $(SRCDIR)/utils/sb2-init $(prefix)/bin/sb2-init
+ $(Q)install -c -m 755 $(SRCDIR)/utils/sb2-config $(prefix)/bin/sb2-config
+@@ -210,10 +212,10 @@ install-noarch: regular
+ ifeq ($(MACH),x86_64)
+ install: install-multilib
+ else
+-install: do-install
++install: install-singlelib
+ endif
+
+-do-install: install-noarch
++install-singlelib: install-noarch
+ $(P)INSTALL
+ @if [ -d $(prefix)/lib ] ; \
+ then echo "$(prefix)/lib present" ; \
+@@ -221,9 +223,6 @@ do-install: install-noarch
+ fi
+ $(Q)install -d -m 755 $(prefix)/lib/libsb2
+ $(Q)install -c -m 755 $(OBJDIR)/preload/libsb2.$(SHLIBEXT) $(prefix)/lib/libsb2/libsb2.so.$(PACKAGE_VERSION)
+- $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-show $(prefix)/bin/sb2-show
+- $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-monitor $(prefix)/bin/sb2-monitor
+- $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-interp-wrapper $(prefix)/bin/sb2-interp-wrapper
+ ifeq ($(OS),Linux)
+ $(Q)/sbin/ldconfig -n $(prefix)/lib/libsb2
+ endif
+@@ -232,9 +231,9 @@ multilib_prefix=$(prefix)
+
+ install-multilib: multilib
+ @$(MAKE) -C obj-32 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=32
+- @$(MAKE) -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. do-install
++ @$(MAKE) -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=64
+
+-do-install-multilib:
++do-install-multilib: install-noarch
+ $(P)INSTALL
+ @if [ -d $(multilib_prefix)/lib$(bitness) ] ; \
+ then echo "$(prefix)/lib$(bitness) present" ; \
+diff --git a/utils/Makefile b/utils/Makefile
+index cf9b6c4..79304fc 100644
+--- a/utils/Makefile
++++ b/utils/Makefile
+@@ -1,7 +1,7 @@
+ # beware of namespace collisions, all subdir makefiles are included
+ # into the top-level Makefile
+
+-$(D)/sb2-show: CFLAGS := $(CFLAGS) -Wall -W -Werror \
++$(D)/sb2-show: CFLAGS := $(CFLAGS) -Wall -W \
+ -I$(SRCDIR)/preload -Ipreload/ $(PROTOTYPEWARNINGS) \
+ -I$(SRCDIR)/include
+
+@@ -12,7 +12,7 @@ $(D)/sb2-show: preload/libsb2.$(SHLIBEXT) $(D)/sb2-show.o
+ $(Q)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+
+-$(D)/sb2-monitor: CFLAGS := $(CFLAGS) -Wall -W -Werror \
++$(D)/sb2-monitor: CFLAGS := $(CFLAGS) -Wall -W \
+ -I$(SRCDIR)/preload -Ipreload/ $(PROTOTYPEWARNINGS) \
+ -I$(SRCDIR)/include
+
+@@ -21,7 +21,7 @@ $(D)/sb2-monitor: $(D)/sb2-monitor.o
+ $(P)LD
+ $(Q)$(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^
+
+-$(D)/sb2-interp-wrapper: CFLAGS := $(CFLAGS) -Wall -W -Werror \
++$(D)/sb2-interp-wrapper: CFLAGS := $(CFLAGS) -Wall -W \
+ -I$(SRCDIR)/preload -Ipreload/ $(PROTOTYPEWARNINGS) \
+ -I$(SRCDIR)/include
+
diff --git a/dev-embedded/scratchbox2/files/scratchbox2-2.0-glibc-2.10.patch b/dev-embedded/scratchbox2/files/scratchbox2-2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..c5ec6aea4341
--- /dev/null
+++ b/dev-embedded/scratchbox2/files/scratchbox2-2.0-glibc-2.10.patch
@@ -0,0 +1,39 @@
+diff --git a/preload/interface.master b/preload/interface.master
+index 55a9481..4ba22b2 100644
+--- a/preload/interface.master
++++ b/preload/interface.master
+@@ -406,20 +406,34 @@ WRAP: int rmdir(const char *pathname) : \
+
+ #ifdef HAVE_SCANDIR
+ #ifdef HAVE_LINUX_SCANDIR
++#if _POSIX_C_SOURCE == 200809L
++WRAP: int scandir(const char *dir, struct dirent ***namelist, \
++ SCANDIR_TYPE_ARG3, \
++ int(*compar)(const struct dirent **, const struct dirent **)) : \
++ map(dir) hardcode_param(3,filter)
++#else
+ WRAP: int scandir(const char *dir, struct dirent ***namelist, \
+ SCANDIR_TYPE_ARG3, int(*compar)(const void *, const void *)) : \
+ map(dir) hardcode_param(3,filter)
+ #endif
++#endif
+ #ifdef HAVE_OSX_SCANDIR
+ WRAP: int scandir(const char *dirname, struct dirent ***namelist, int (*select)(struct dirent *), int (*compar)(const void *, const void *)): map(dirname)
+ #endif
+ #endif
+ #ifdef HAVE_SCANDIR64
++#if _POSIX_C_SOURCE == 200809L
++WRAP: int scandir64(const char *dir, struct dirent64 ***namelist, \
++ int(*filter)(const struct dirent64 *), \
++ int(*compar)(const struct dirent64 **, const struct dirent64 **)) : \
++ map(dir)
++#else
+ WRAP: int scandir64(const char *dir, struct dirent64 ***namelist, \
+ int(*filter)(const struct dirent64 *), \
+ int(*compar)(const void *, const void *)) : \
+ map(dir)
+ #endif
++#endif
+ #ifdef HAVE_SETXATTR
+ #ifdef HAVE_LINUX_XATTRS
+ WRAP: int setxattr(const char *path, const char *name, const void *value, \
diff --git a/dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch b/dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch
new file mode 100644
index 000000000000..d4c231c74db2
--- /dev/null
+++ b/dev-embedded/scratchbox2/files/scratchbox2-2.0-use-system-lua.patch
@@ -0,0 +1,77 @@
+diff --git a/Makefile b/Makefile
+index c5b26cc..da48ea0 100644
+--- a/Makefile
++++ b/Makefile
+@@ -60,7 +60,7 @@ subdirs = luaif preload utils
+ -include config.mak
+
+ CFLAGS += -I$(OBJDIR)/include -I$(SRCDIR)/include
+-CFLAGS += -I$(SRCDIR)/luaif/lua-5.1.4/src
++# CFLAGS += -I$(SRCDIR)/luaif/lua-5.1.4/src
+ CFLAGS += -D_GNU_SOURCE=1 -D_LARGEFILE_SOURCE=1 -D_LARGEFILE64_SOURCE=1
+ CFLAGS += -DSCRATCHBOX_ROOT="$(prefix)"
+ CFLAGS += $(MACH_CFLAG)
+@@ -103,10 +103,7 @@ regular: .configure .version
+ @$(MAKE) -f $(SRCDIR)/Makefile --include-dir=$(SRCDIR) SRCDIR=$(SRCDIR) do-all
+
+ multilib:
+- @mkdir -p obj-32
+- @mkdir -p obj-64
+- @$(MAKE) MACH_CFLAG=-m32 -C obj-32 --include-dir=.. -f ../Makefile SRCDIR=.. regular
+- @$(MAKE) MACH_CFLAG=-m64 -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. regular
++ @$(MAKE) MACH_CFLAG=-m64 regular
+
+
+ gcc_bins = addr2line ar as cc c++ c++filt cpp g++ gcc gcov gdb gdbtui gprof ld nm objcopy objdump ranlib rdi-stub readelf run size strings strip
+@@ -230,8 +227,7 @@ endif
+ multilib_prefix=$(prefix)
+
+ install-multilib: multilib
+- @$(MAKE) -C obj-32 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=32
+- @$(MAKE) -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=64
++ @$(MAKE) do-install-multilib bitness=64
+
+ do-install-multilib: install-noarch
+ $(P)INSTALL
+diff --git a/luaif/Makefile b/luaif/Makefile
+index 28e8885..5e1af6f 100644
+--- a/luaif/Makefile
++++ b/luaif/Makefile
+@@ -5,7 +5,7 @@ objs := $(D)/luaif.o $(D)/sb_log.o $(D)/paths.o $(D)/argvenvp.o
+ $(D)/sb_log.o: preload/exported.h
+
+ luaif/libluaif.a: $(objs)
+-luaif/libluaif.a: override CFLAGS := $(CFLAGS) -O2 -g -fPIC -Wall -W -I$(SRCDIR)/$(LUASRC) -I$(OBJDIR)/preload -I$(SRCDIR)/preload
++luaif/libluaif.a: override CFLAGS := $(CFLAGS) -O2 -g -fPIC -Wall -W -I$(OBJDIR)/preload -I$(SRCDIR)/preload
+ luaif/libluaif.a: override LDFLAGS := $(LDFLAGS)
+ luaif/libluaif.a: override LIBS :=
+
+@@ -24,5 +24,5 @@ luaif/liblua.a: override CFLAGS := -O2 -g -fPIC -Wall -W $(CFLAGS)
+ luaif/liblua.a: override LDFLAGS := $(LDFLAGS)
+ luaif/liblua.a: override LIBS :=
+
+-targets := $(targets) $(D)/libluaif.a $(D)/liblua.a
++targets := $(targets) $(D)/libluaif.a
+
+diff --git a/preload/Makefile b/preload/Makefile
+index 9f785ba..5094dbc 100644
+--- a/preload/Makefile
++++ b/preload/Makefile
+@@ -8,7 +8,7 @@ LIBSB2_LDFLAGS = -Wl,-soname=$(LIBSB2_SONAME) \
+ # DO NOT add any libraries that depend on libpthread to
+ # LIBSB2_LIBS or LIBS!! see the comments in luaif.c.
+
+-LIBSB2_LIBS =
++LIBSB2_LIBS = -llua
+ SHLIBEXT = so
+ else
+ LIBSB2_LIBS =
+@@ -17,7 +17,7 @@ endif
+
+
+ $(D)/libsb2.$(SHLIBEXT): $(call O,$(objs))
+-$(D)/libsb2.$(SHLIBEXT): luaif/libluaif.a luaif/liblua.a
++$(D)/libsb2.$(SHLIBEXT): luaif/libluaif.a
+ $(D)/libsb2.$(SHLIBEXT): CFLAGS := $(CFLAGS) -fPIC -Wall -W \
+ -I$(SRCDIR)/preload -Ipreload/ $(PROTOTYPEWARNINGS)
+ $(D)/libsb2.$(SHLIBEXT): LDFLAGS := $(LDFLAGS) $(LIBSB2_LDFLAGS)