summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild')
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild
deleted file mode 100644
index 3a0bedb4ecfe..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2015.01.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="5"
-
-inherit eutils toolchain-funcs
-
-MY_P="u-boot-${PV/_/-}"
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- # Unset a few KBUILD variables. Bug #540476
- unset KBUILD_OUTPUT KBUILD_SRC
- emake defconfig
- emake \
- HOSTSTRIP=: \
- HOSTCC="$(tc-getCC)" \
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
- HOSTLDFLAGS="${LDFLAGS}" \
- CONFIG_ENV_OVERWRITE=y \
- tools-all
-}
-
-src_install() {
- cd tools
- dobin bmp_logo gen_eth_addr img2srec mkimage
- dobin easylogo/easylogo
- dobin env/fw_printenv
- dosym fw_printenv /usr/bin/fw_setenv
- insinto /etc
- doins env/fw_env.config
-}