summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
index 92b7d18e73fb..7bf924633a93 100644
--- a/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2022.04.ebuild
@@ -34,6 +34,7 @@ src_prepare() {
src_configure() {
tc-export AR BUILD_CC CC PKG_CONFIG
+ tc-export_build_env
}
src_compile() {
@@ -45,8 +46,8 @@ src_compile() {
AR="${AR}"
CC="${CC}"
HOSTCC="${BUILD_CC}"
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)'
- HOSTLDFLAGS="${LDFLAGS}"
+ HOSTCFLAGS="${BUILD_CFLAGS} ${BUILD_CPPFLAGS}"' $(HOSTCPPFLAGS)'
+ HOSTLDFLAGS="${BUILD_LDFLAGS}"
)
emake "${myemakeargs[@]}" tools-only_defconfig