summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/mygui')
-rw-r--r--dev-games/mygui/Manifest4
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-build.patch61
-rw-r--r--dev-games/mygui/files/mygui-3.2.2-underlinking.patch20
-rw-r--r--dev-games/mygui/files/mygui-3.4.0-underlinking.patch21
-rw-r--r--dev-games/mygui/files/mygui-3.4.1-FHS.patch (renamed from dev-games/mygui/files/mygui-3.2.2-FHS.patch)17
-rw-r--r--dev-games/mygui/files/mygui-3.4.1-build.patch (renamed from dev-games/mygui/files/mygui-3.4.0-build.patch)9
-rw-r--r--dev-games/mygui/files/mygui-3.4.1-gcc13.patch23
-rw-r--r--dev-games/mygui/files/mygui-3.4.3-werror.patch12
-rw-r--r--dev-games/mygui/metadata.xml2
-rw-r--r--dev-games/mygui/mygui-3.4.1-r1.ebuild (renamed from dev-games/mygui/mygui-3.4.0.ebuild)35
-rw-r--r--dev-games/mygui/mygui-3.4.3.ebuild (renamed from dev-games/mygui/mygui-3.2.2.ebuild)103
11 files changed, 115 insertions, 192 deletions
diff --git a/dev-games/mygui/Manifest b/dev-games/mygui/Manifest
index 0a6549d14952..0be3a4c3b634 100644
--- a/dev-games/mygui/Manifest
+++ b/dev-games/mygui/Manifest
@@ -1,2 +1,2 @@
-DIST MyGUI3.2.2.tar.gz 22081236 BLAKE2B 3a28e0838a8203d20565822d5a19423a733149cca250dc4169de43f22beb7d37fccbf3d282ea9b4f284cb71df2df9a9073bac40124e1d8a90d15c5fda2af798a SHA512 1290ce1d78b9e4bfe72bea3fb1bc6cdd25969b44be2844df62a1f425b3e221a68b61658fdf45271fb50a1957f12b5ada1c9be971e00ecfe41f53ae0a83ae18d4
-DIST mygui-3.4.0.tar.gz 22391483 BLAKE2B 5628cca98625285368b9363acd95e541e1ba7d86fd1d471f687c553d0f0abd9ccb2f47981cf0bb91f44a68489bb7ec3fbcb451734758e2435ab9ef320214465a SHA512 3f560fd9c7e5b514da40e41c7753dc20649f80b763f5ee20afc9627df3be14242ea833eff09eac16b9e88b1c9fbed7c09def0c5068c832e710c247191fb53487
+DIST mygui-3.4.1.tar.gz 22433198 BLAKE2B 400f88a63df1bff5554236a0aeb58218fdb6100aa84f9eb1ac111adabfa45ae7eb1c3124bb04f3ef57587566e716d3242daa9cb5866d7ccc43a56c9605952411 SHA512 9d36272345b1a755db88848c8a0919feb6f8ae09d048efa3b8ed833bb5ddb9c65e1e7e0d26ad39eecd2a4de53fb654f4099c555e9ebd21ce9541a1a74580ef05
+DIST mygui-3.4.3.tar.gz 18797995 BLAKE2B 8329e63bdef7201f6a810fd5f4d85e36e0cf48f74f769c4e0f7c026ccae397274debe49ad71ba4a30d251cfba00ee99bcf73ed7424d4f878d769793aef985cf1 SHA512 88c69ca2e706af364b72d425f95013eb285501881d8094f8d67e31a54c45ca11b0eb5b62c382af0d4c43f69aa8197648259ac306b72efa7ef3e25eecb9b039cb
diff --git a/dev-games/mygui/files/mygui-3.2.2-build.patch b/dev-games/mygui/files/mygui-3.2.2-build.patch
deleted file mode 100644
index a16b27c285b7..000000000000
--- a/dev-games/mygui/files/mygui-3.2.2-build.patch
+++ /dev/null
@@ -1,61 +0,0 @@
-diff -ru mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake
---- mygui-MyGUI3.2.2.orig/CMake/ConfigureBuild.cmake 2015-01-26 10:32:35.000000000 -0500
-+++ mygui-MyGUI3.2.2/CMake/ConfigureBuild.cmake 2015-03-14 01:09:40.743621643 -0400
-@@ -4,6 +4,8 @@
- # also prepare package files for pkg-config and CMake.
- #######################################################################
-
-+include(GNUInstallDirs)
-+
- # should we build static libs?
- if (MYGUI_STATIC)
- set(MYGUI_LIB_TYPE STATIC)
-@@ -47,7 +49,7 @@
- else ()
- configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
- endif ()
-- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
-+ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
- # configure additional packages
-
-diff -ru mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake
---- mygui-MyGUI3.2.2.orig/CMake/Utils/MyGUIConfigTargets.cmake 2015-01-26 10:32:35.000000000 -0500
-+++ mygui-MyGUI3.2.2/CMake/Utils/MyGUIConfigTargets.cmake 2015-03-14 01:08:44.905791784 -0400
-@@ -1,6 +1,8 @@
- # Configure settings and install targets
- # FIXME: Copypasted from Ogre and need lots of changes
-
-+include(GNUInstallDirs)
-+
- if (WIN32)
- set(MYGUI_RELEASE_PATH "/Release")
- set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
-@@ -60,6 +62,12 @@
- # install targets according to current build type
- function(mygui_install_target TARGETNAME SUFFIX)
- install(TARGETS ${TARGETNAME}
-+ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
-+ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
-+ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
-+ )
-+ install(TARGETS ${TARGETNAME}
- RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
- LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
- ARCHIVE DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
-@@ -171,7 +179,13 @@
- endif ()
- add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
- endif ()
-- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+
-+ # rename demo target^M
-+ if (${SOLUTIONFOLDER} STREQUAL "Demos")
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
-+ else()
-+ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
-+ endif()
-
- add_dependencies(${PROJECTNAME} MyGUIEngine Common)
-
diff --git a/dev-games/mygui/files/mygui-3.2.2-underlinking.patch b/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
deleted file mode 100644
index 2d1026856f03..000000000000
--- a/dev-games/mygui/files/mygui-3.2.2-underlinking.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jun 15 10:42:42 UTC 2012
-Subject: build system
-
-fix underlinking
-
---- MyGUIEngine/CMakeLists.txt
-+++ MyGUIEngine/CMakeLists.txt
-@@ -48,7 +48,10 @@
- if (MYGUI_USE_FREETYPE)
- target_link_libraries(${PROJECTNAME}
- ${FREETYPE_LIBRARIES}
-- )
-+ dl)
-+else()
-+ target_link_libraries(${PROJECTNAME}
-+ dl)
- endif()
-
- # platform specific dependencies
diff --git a/dev-games/mygui/files/mygui-3.4.0-underlinking.patch b/dev-games/mygui/files/mygui-3.4.0-underlinking.patch
deleted file mode 100644
index 1dcf2dbbbfda..000000000000
--- a/dev-games/mygui/files/mygui-3.4.0-underlinking.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From: Julian Ospald <hasufell@gentoo.org>
-Date: Fri Jun 15 10:42:42 UTC 2012
-Subject: build system
-
-fix underlinking
-
-diff --git a/MyGUIEngine/CMakeLists.txt b/MyGUIEngine/CMakeLists.txt
---- a/MyGUIEngine/CMakeLists.txt
-+++ b/MyGUIEngine/CMakeLists.txt
-@@ -44,7 +44,10 @@ if (MYGUI_USE_FREETYPE)
- target_link_libraries(${PROJECTNAME}
- ${FREETYPE_LIBRARIES}
- ${ZLIB_LIBRARIES}
-- )
-+ dl)
-+else()
-+ target_link_libraries(${PROJECTNAME}
-+ dl)
- endif()
-
- # platform specific dependencies
diff --git a/dev-games/mygui/files/mygui-3.2.2-FHS.patch b/dev-games/mygui/files/mygui-3.4.1-FHS.patch
index 14d21626ff7b..b6d7bbe8e327 100644
--- a/dev-games/mygui/files/mygui-3.2.2-FHS.patch
+++ b/dev-games/mygui/files/mygui-3.4.1-FHS.patch
@@ -24,21 +24,4 @@ paths hardcoded until upstream fixed the logic
else ()
set(MYGUI_MEDIA_DIR "../../Media")
endif ()
---- mygui-MyGUI3.2.2.orig/Common/Base/Ogre/BaseManager.cpp
-+++ mygui-MyGUI3.2.2/Common/Base/Ogre/BaseManager.cpp
-@@ -49,13 +49,13 @@
- mWindow(nullptr),
- mExit(false),
- mPluginCfgName("plugins.cfg"),
-- mResourceXMLName("resources.xml"),
-+ mResourceXMLName("/etc/MYGUI/resources.xml"),
- mResourceFileName("MyGUI_Core.xml")
- {
- #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
- mResourcePath = macBundlePath() + "/Contents/Resources/";
- #else
-- mResourcePath = "";
-+ mResourcePath = "/etc/MYGUI/";
- #endif
- }
diff --git a/dev-games/mygui/files/mygui-3.4.0-build.patch b/dev-games/mygui/files/mygui-3.4.1-build.patch
index 71ed87d8bcb8..5729be5d4380 100644
--- a/dev-games/mygui/files/mygui-3.4.0-build.patch
+++ b/dev-games/mygui/files/mygui-3.4.1-build.patch
@@ -10,15 +10,6 @@ diff --git a/CMake/ConfigureBuild.cmake b/CMake/ConfigureBuild.cmake
# should we build static libs?
if (MYGUI_STATIC)
set(MYGUI_LIB_TYPE STATIC)
-@@ -47,7 +49,7 @@ if (UNIX)
- else ()
- configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
- endif ()
-- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
-+ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
-
- # configure additional packages
-
diff --git a/CMake/Utils/MyGUIConfigTargets.cmake b/CMake/Utils/MyGUIConfigTargets.cmake
--- a/CMake/Utils/MyGUIConfigTargets.cmake
+++ b/CMake/Utils/MyGUIConfigTargets.cmake
diff --git a/dev-games/mygui/files/mygui-3.4.1-gcc13.patch b/dev-games/mygui/files/mygui-3.4.1-gcc13.patch
new file mode 100644
index 000000000000..542df19bcfc5
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.4.1-gcc13.patch
@@ -0,0 +1,23 @@
+https://github.com/MyGUI/mygui/pull/249
+
+From f97c85b4e096379f728700d61c2f5780043dfc0a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 18 Apr 2023 12:29:08 +0100
+Subject: [PATCH] Fix build with GCC 13
+
+GCC 13 (as usual for new compiler releases) shuffles around some internal includes so some
+are no longer transitively included.
+
+See https://gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Bug: https://bugs.gentoo.org/895098
+--- a/MyGUIEngine/include/MyGUI_Types.h
++++ b/MyGUIEngine/include/MyGUI_Types.h
+@@ -9,6 +9,7 @@
+
+ #include "MyGUI_Prerequest.h"
+
++#include <cstdint>
+ #include <vector>
+ #include <map>
+ #include <string>
diff --git a/dev-games/mygui/files/mygui-3.4.3-werror.patch b/dev-games/mygui/files/mygui-3.4.3-werror.patch
new file mode 100644
index 000000000000..d001c9e48baf
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.4.3-werror.patch
@@ -0,0 +1,12 @@
+Remove -Werror
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -174,7 +174,6 @@ include(Dependencies)
+
+ # Set compiler specific build flags
+ if (CMAKE_COMPILER_IS_GNUCXX OR CMAKE_CXX_COMPILER_ID MATCHES "Clang" OR CMAKE_CXX_COMPILER_ID MATCHES "Intel")
+- add_compile_options(-Werror)
+ if (NOT MYGUI_HIGH_LEVEL_WARNINGS)
+ add_compile_options(-w)
+ else ()
diff --git a/dev-games/mygui/metadata.xml b/dev-games/mygui/metadata.xml
index 9c40bc645ee4..24fe1f1c9e2e 100644
--- a/dev-games/mygui/metadata.xml
+++ b/dev-games/mygui/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>games@gentoo.org</email>
diff --git a/dev-games/mygui/mygui-3.4.0.ebuild b/dev-games/mygui/mygui-3.4.1-r1.ebuild
index 896d211683f2..749f0fb91765 100644
--- a/dev-games/mygui/mygui-3.4.0.ebuild
+++ b/dev-games/mygui/mygui-3.4.1-r1.ebuild
@@ -1,11 +1,10 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-CMAKE_REMOVE_MODULES="yes"
CMAKE_REMOVE_MODULES_LIST="FindFreetype"
-inherit cmake-utils flag-o-matic multilib
+inherit cmake flag-o-matic
MY_PN=MyGUI
MY_P=${MY_PN}${PV}
@@ -16,8 +15,8 @@ SRC_URI="https://github.com/MyGUI/mygui/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc +ogre -opengl plugins samples static-libs test tools l10n_ru"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="debug doc +ogre opengl plugins samples static-libs test tools l10n_ru"
RESTRICT="!test? ( test )"
REQUIRED_USE="ogre? ( !opengl )
opengl? ( !ogre )"
@@ -25,7 +24,7 @@ REQUIRED_USE="ogre? ( !opengl )
RDEPEND="media-libs/freetype:2
sys-libs/zlib
ogre? (
- dev-games/ogre:0=[freeimage,opengl]
+ >=dev-games/ogre-1.12:0=[freeimage,opengl]
samples? ( dev-games/ois )
)
opengl? (
@@ -35,15 +34,15 @@ RDEPEND="media-libs/freetype:2
tools? ( dev-games/ois )"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+ doc? ( app-text/doxygen )"
S=${WORKDIR}/mygui-${MY_P}
STATIC_BUILD=${WORKDIR}/${P}_build_static
PATCHES=(
- "${FILESDIR}"/${P}-underlinking.patch
"${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${PN}-3.2.2-FHS.patch
+ "${FILESDIR}"/${P}-FHS.patch
+ "${FILESDIR}"/${P}-gcc13.patch
)
pkg_setup() {
@@ -64,15 +63,15 @@ src_configure() {
-DMYGUI_BUILD_DOCS=OFF
-DMYGUI_INSTALL_DOCS=OFF
-DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
+ -DMYGUI_BUILD_PLUGINS=$(usex plugins)
-DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
+ -DMYGUI_INSTALL_DEMOS=OFF
-DMYGUI_BUILD_TOOLS=OFF
-DMYGUI_INSTALL_TOOLS=OFF
-DMYGUI_BUILD_WRAPPER=OFF
-DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_configure
+ CMAKE_BUILD_DIR=${STATIC_BUILD} cmake_src_configure
unset mycmakeargs
fi
@@ -93,12 +92,12 @@ src_configure() {
if use ogre && use samples; then
mycmakeargs+=(
-DMYGUI_BUILD_DEMOS=ON
- -DMYGUI_INSTALL_SAMPLES=ON
+ -DMYGUI_INSTALL_DEMOS=ON
)
else
mycmakeargs+=(
-DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
+ -DMYGUI_INSTALL_DEMOS=OFF
)
fi
@@ -109,23 +108,23 @@ src_configure() {
mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=OFF )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
# build system does not support building static and shared at once,
# run a double build
if use static-libs ; then
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_compile
+ CMAKE_BUILD_DIR=${STATIC_BUILD} cmake_src_compile
fi
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C "${CMAKE_BUILD_DIR}"/Docs api-docs
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use static-libs ; then
find "${STATIC_BUILD}" -name "*.a" \! -name "libCommon.a" -exec dolib.a '{}' \;
diff --git a/dev-games/mygui/mygui-3.2.2.ebuild b/dev-games/mygui/mygui-3.4.3.ebuild
index ac582627a70d..b8690f9d6bc9 100644
--- a/dev-games/mygui/mygui-3.2.2.ebuild
+++ b/dev-games/mygui/mygui-3.4.3.ebuild
@@ -1,46 +1,48 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-CMAKE_REMOVE_MODULES="yes"
-CMAKE_REMOVE_MODULES_LIST="FindFreetype"
-inherit eutils cmake-utils flag-o-matic multilib
+EAPI=8
+
+CMAKE_REMOVE_MODULES_LIST=(FindFreetype)
+inherit cmake flag-o-matic
MY_PN=MyGUI
MY_P=${MY_PN}${PV}
-DESCRIPTION="A library for creating GUIs for games"
-HOMEPAGE="http://mygui.info/"
-SRC_URI="https://github.com/MyGUI/mygui/archive/${MY_P}.tar.gz"
+DESCRIPTION="A library for creating GUIs for games and 3D applications"
+HOMEPAGE="http://mygui.info"
+SRC_URI="https://github.com/MyGUI/mygui/archive/${MY_P}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc +ogre -opengl plugins samples static-libs test tools l10n_ru"
+SLOT="0/${PV}" # soname
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="debug doc +ogre opengl plugins samples static-libs test tools l10n_ru"
RESTRICT="!test? ( test )"
REQUIRED_USE="ogre? ( !opengl )
opengl? ( !ogre )"
-RDEPEND="
- media-libs/freetype:2
+RDEPEND="media-libs/freetype:2
+ sys-libs/zlib
ogre? (
- dev-games/ogre:=[freeimage,opengl]
+ >=dev-games/ogre-1.12:0=[freeimage,opengl]
samples? ( dev-games/ois )
)
- opengl? ( virtual/opengl
- media-libs/glew )
+ opengl? (
+ virtual/opengl
+ media-libs/glew:0=
+ )
tools? ( dev-games/ois )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- doc? ( app-doc/doxygen )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ doc? ( app-text/doxygen )"
S=${WORKDIR}/mygui-${MY_P}
STATIC_BUILD=${WORKDIR}/${P}_build_static
PATCHES=(
- "${FILESDIR}"/${P}-underlinking.patch
- "${FILESDIR}"/${P}-build.patch
- "${FILESDIR}"/${P}-FHS.patch
+ "${FILESDIR}"/mygui-3.4.1-build.patch
+ "${FILESDIR}"/mygui-3.4.1-FHS.patch
+ "${FILESDIR}"/mygui-3.4.3-werror.patch
)
pkg_setup() {
@@ -58,34 +60,49 @@ src_configure() {
# static configuration
if use static-libs ; then
mycmakeargs=( -DMYGUI_STATIC=ON
+ -DMYGUI_DONT_USE_OBSOLETE=ON
-DMYGUI_BUILD_DOCS=OFF
-DMYGUI_INSTALL_DOCS=OFF
-DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
+ -DMYGUI_BUILD_PLUGINS=$(usex plugins)
-DMYGUI_BUILD_DEMOS=OFF
- -DMYGUI_INSTALL_SAMPLES=OFF
+ -DMYGUI_INSTALL_DEMOS=OFF
-DMYGUI_BUILD_TOOLS=OFF
-DMYGUI_INSTALL_TOOLS=OFF
-DMYGUI_BUILD_WRAPPER=OFF
-DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_configure
+ CMAKE_BUILD_DIR=${STATIC_BUILD} cmake_src_configure
unset mycmakeargs
fi
# main configuration
- mycmakeargs=( -DMYGUI_STATIC=OFF
- $(cmake-utils_use doc MYGUI_BUILD_DOCS)
- $(cmake-utils_use doc MYGUI_INSTALL_DOCS)
+ mycmakeargs=(
+ -DMYGUI_STATIC=OFF
+ -DMYGUI_BUILD_DOCS=$(usex doc)
+ -DMYGUI_INSTALL_DOCS=$(usex doc)
-DMYGUI_USE_FREETYPE=ON
- $(cmake-utils_use plugins MYGUI_BUILD_PLUGINS)
- $(usex ogre "$(cmake-utils_use samples MYGUI_BUILD_DEMOS)" "-DMYGUI_BUILD_DEMOS=OFF")
- $(usex ogre "$(cmake-utils_use samples MYGUI_INSTALL_SAMPLES)" "-DMYGUI_INSTALL_SAMPLES=OFF")
- $(cmake-utils_use tools MYGUI_BUILD_TOOLS)
- $(cmake-utils_use tools MYGUI_INSTALL_TOOLS)
- $(cmake-utils_use opengl MYGUI_USE_SYSTEM_GLEW)
+ -DMYGUI_BUILD_PLUGINS=$(usex plugins)
+ -DMYGUI_BUILD_TOOLS=$(usex tools)
+ -DMYGUI_INSTALL_TOOLS=$(usex tools)
+ -DMYGUI_USE_SYSTEM_GLEW=$(usex opengl)
-DMYGUI_BUILD_WRAPPER=OFF
- -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")") )
+ -DMYGUI_DONT_USE_OBSOLETE=ON
+ -DMYGUI_RENDERSYSTEM=$(usex opengl "4" "$(usex ogre "3" "1")")
+ )
+
+ if use ogre && use samples; then
+ mycmakeargs+=(
+ -DMYGUI_BUILD_DEMOS=ON
+ -DMYGUI_INSTALL_DEMOS=ON
+ )
+ else
+ mycmakeargs+=(
+ -DMYGUI_BUILD_DEMOS=OFF
+ -DMYGUI_INSTALL_DEMOS=OFF
+ )
+
+ fi
if use tools || (use samples && use ogre) ; then
mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=ON )
@@ -93,23 +110,23 @@ src_configure() {
mycmakeargs+=( -DMYGUI_INSTALL_MEDIA=OFF )
fi
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
# build system does not support building static and shared at once,
# run a double build
if use static-libs ; then
- CMAKE_BUILD_DIR=${STATIC_BUILD} cmake-utils_src_compile
+ CMAKE_BUILD_DIR=${STATIC_BUILD} cmake_src_compile
fi
- cmake-utils_src_compile
+ cmake_src_compile
use doc && emake -C "${CMAKE_BUILD_DIR}"/Docs api-docs
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
if use static-libs ; then
find "${STATIC_BUILD}" -name "*.a" \! -name "libCommon.a" -exec dolib.a '{}' \;
@@ -118,7 +135,7 @@ src_install() {
fi
if use doc ; then
- dohtml -r "${CMAKE_BUILD_DIR}"/Docs/html/*
+ dodoc -r "${CMAKE_BUILD_DIR}"/Docs/html/
if use l10n_ru ; then
docompress -x /usr/share/doc/${PF}/Papers
@@ -130,14 +147,14 @@ src_install() {
fperms o+w /etc/MYGUI
# test media not needed at runtime
- rm -rf "${ED%/}"/usr/share/MYGUI/Media/UnitTests || die
+ rm -rf "${ED}"/usr/share/MYGUI/Media/UnitTests || die
# wrapper not available for linux, remove related media
- rm -rf "${ED%/}"/usr/share/MYGUI/Media/Wrapper || die
+ rm -rf "${ED}"/usr/share/MYGUI/Media/Wrapper || die
}
pkg_postinst() {
elog
elog "ogre.cfg and Ogre.log are created as"
- elog "${EROOT%/}/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
+ elog "${EROOT}/etc/MYGUI/mygui-ogre.cfg and /etc/MYGUI/mygui-Ogre.log"
elog
}