summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/ode')
-rw-r--r--dev-games/ode/Manifest2
-rw-r--r--dev-games/ode/metadata.xml4
-rw-r--r--dev-games/ode/ode-0.11.1.ebuild72
-rw-r--r--dev-games/ode/ode-0.12.ebuild72
-rw-r--r--dev-games/ode/ode-0.14-r1.ebuild57
5 files changed, 39 insertions, 168 deletions
diff --git a/dev-games/ode/Manifest b/dev-games/ode/Manifest
index 4528a5fa39c7..77d310fc155f 100644
--- a/dev-games/ode/Manifest
+++ b/dev-games/ode/Manifest
@@ -1,3 +1 @@
-DIST ode-0.11.1.tar.bz2 1720088 BLAKE2B 0908356d45e9b17af80cc2afefd3a09735c4955d0a03b502a60f0bd01023796c3b00b1caf379eac354d7754035db11bcdf802c1ecc72abd28a9fce7e1dd7eef1 SHA512 1e015231f4d01c68e7539144d197031cca23d4b58ea53733184a826ce23388956c428a53385254e7eed2c5d3fc28224a688eb13be7ea648bd78e186c8f203d37
-DIST ode-0.12.tar.bz2 1816246 BLAKE2B 7ac4b9158f6672775e0374a619f71a178cb8a3a1cf8c957d67c2547081a9dd660a091923fec364133dfbe4cd6b82cfe14961bda8994bb6241aa9e1af61ef22ef SHA512 303ffda8afcb89a87d09c44393f590f5646f10e8959ca06746121859ad2407709cd711ab185fed4817a9f74c9ca4ee13d1698a28577211bf65dbaad1141f6fc0
DIST ode-0.14.tar.gz 4018146 BLAKE2B 7dbb3d4cd673dabce176cf92d9d0b5fdd21dea25b751b8b43fd99a71e7806170fb97459dc2ecc7a9cbd14bf54bd32b4a3e631b78a1c3420ebc11c2d518f0eb45 SHA512 1f74c3c4687ee9665fa70e65a79100747fba577729830a90806e374115f1c161a2f4545cf591b0979054aa3e2f9a3673635668cb7362ab5c213ada0d39b1a03d
diff --git a/dev-games/ode/metadata.xml b/dev-games/ode/metadata.xml
index bc254df5ec9a..b1da0ee24971 100644
--- a/dev-games/ode/metadata.xml
+++ b/dev-games/ode/metadata.xml
@@ -1,5 +1,5 @@
-<?xml version='1.0' encoding='UTF-8'?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>games@gentoo.org</email>
diff --git a/dev-games/ode/ode-0.11.1.ebuild b/dev-games/ode/ode-0.11.1.ebuild
deleted file mode 100644
index b20a61d98648..000000000000
--- a/dev-games/ode/ode-0.11.1.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils ltprune
-
-DESCRIPTION="Open Dynamics Engine SDK"
-HOMEPAGE="http://ode.org/"
-SRC_URI="mirror://sourceforge/opende/${P}.tar.bz2"
-
-LICENSE="|| ( LGPL-2.1 BSD )"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="debug doc double-precision examples gyroscopic static-libs"
-
-RDEPEND="examples? (
- virtual/opengl
- )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- sed -i \
- -e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
- drawstuff/src/Makefile.in \
- ode/demo/Makefile.in || die
-}
-
-src_configure() {
- # use bash (bug #335760)
- CONFIG_SHELL=/bin/bash \
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug asserts) \
- $(use_enable double-precision) \
- $(use_enable examples demos) \
- $(use_enable gyroscopic) \
- $(use_with examples drawstuff X11)
-}
-
-src_compile() {
- emake
- if use doc ; then
- cd ode/doc
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- DOCS="CHANGELOG.txt README.txt" \
- default
- prune_libtool_files
- if use doc ; then
- dohtml docs/*
- fi
- if use examples; then
- cd ode/demo
- exeinto /usr/share/doc/${PF}/examples
- local f
- for f in *.c* ; do
- doexe .libs/${f%.*}
- done
- cd ../..
- doexe drawstuff/dstest/dstest
- insinto /usr/share/doc/${PF}/examples
- doins ode/demo/*.{c,cpp,h} \
- drawstuff/textures/*.ppm \
- drawstuff/dstest/dstest.cpp \
- drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
- fi
-}
diff --git a/dev-games/ode/ode-0.12.ebuild b/dev-games/ode/ode-0.12.ebuild
deleted file mode 100644
index f9239dc91a8a..000000000000
--- a/dev-games/ode/ode-0.12.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils ltprune
-
-DESCRIPTION="Open Dynamics Engine SDK"
-HOMEPAGE="http://ode.org/"
-SRC_URI="mirror://sourceforge/opende/${P}.tar.bz2"
-
-LICENSE="|| ( LGPL-2.1 BSD )"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug doc double-precision examples gyroscopic static-libs"
-
-RDEPEND="examples? (
- virtual/opengl
- )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
-
-src_prepare() {
- sed -i \
- -e "s:\$.*/drawstuff/textures:/usr/share/doc/${PF}/examples:" \
- drawstuff/src/Makefile.in \
- ode/demo/Makefile.in || die
-}
-
-src_configure() {
- # use bash (bug #335760)
- CONFIG_SHELL=/bin/bash \
- econf \
- --enable-shared \
- $(use_enable static-libs static) \
- $(use_enable debug asserts) \
- $(use_enable double-precision) \
- $(use_enable examples demos) \
- $(use_enable gyroscopic) \
- $(use_with examples drawstuff X11)
-}
-
-src_compile() {
- emake
- if use doc ; then
- cd ode/doc
- doxygen Doxyfile || die
- fi
-}
-
-src_install() {
- DOCS="CHANGELOG.txt README.txt" \
- default
- prune_libtool_files
- if use doc ; then
- dohtml docs/*
- fi
- if use examples; then
- cd ode/demo
- exeinto /usr/share/doc/${PF}/examples
- local f
- for f in *.c* ; do
- doexe .libs/${f%.*}
- done
- cd ../..
- doexe drawstuff/dstest/dstest
- insinto /usr/share/doc/${PF}/examples
- doins ode/demo/*.{c,cpp,h} \
- drawstuff/textures/*.ppm \
- drawstuff/dstest/dstest.cpp \
- drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
- fi
-}
diff --git a/dev-games/ode/ode-0.14-r1.ebuild b/dev-games/ode/ode-0.14-r1.ebuild
index 11a993ae006d..4b47cc5c5a34 100644
--- a/dev-games/ode/ode-0.14-r1.ebuild
+++ b/dev-games/ode/ode-0.14-r1.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils ltprune
+EAPI=7
+
+inherit autotools
DESCRIPTION="Open Dynamics Engine SDK"
HOMEPAGE="http://ode.org/"
@@ -10,19 +11,28 @@ SRC_URI="https://bitbucket.org/odedevs/ode/downloads/${P}.tar.gz"
LICENSE="|| ( LGPL-2.1+ BSD )"
SLOT="0/6"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ~arm64 x86 ~amd64-linux ~x86-linux"
IUSE="debug doc double-precision examples gyroscopic static-libs"
-RDEPEND="examples? (
- virtual/glu
- virtual/opengl )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )"
+RDEPEND="
+ examples? (
+ virtual/glu
+ virtual/opengl
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="doc? ( app-text/doxygen )"
MY_EXAMPLES_DIR=/usr/share/doc/${PF}/examples
+DOCS=( CHANGELOG.txt README.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.14-gcc7.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-0.14-gcc7.patch
+ default
sed -i \
-e "s:\$.*/drawstuff/textures:${MY_EXAMPLES_DIR}:" \
@@ -47,28 +57,35 @@ src_configure() {
src_compile() {
emake
if use doc ; then
- cd ode/doc
+ cd ode/doc || die
doxygen Doxyfile || die
fi
}
src_install() {
- DOCS="CHANGELOG.txt README.md" \
- default
- prune_libtool_files
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
if use doc ; then
- dohtml docs/*
+ docinto html
+ dodoc docs/*
fi
- if use examples; then
- docompress -x "${MY_EXAMPLES_DIR}"
- insinto "${MY_EXAMPLES_DIR}"
- exeinto "${MY_EXAMPLES_DIR}"
+
+ if use examples ; then
+ docompress -x ${MY_EXAMPLES_DIR}
+
+ insinto ${MY_EXAMPLES_DIR}
+ exeinto ${MY_EXAMPLES_DIR}
+
doexe drawstuff/dstest/dstest
doins ode/demo/*.{c,cpp,h} \
drawstuff/textures/*.ppm \
drawstuff/dstest/dstest.cpp \
drawstuff/src/{drawstuff.cpp,internal.h,x11.cpp}
- cd ode/demo
+
+ cd ode/demo || die
+
local f
for f in *.c* ; do
doexe .libs/${f%.*}